**Solved** Pixhawk 2 can't connect USB to MP and QGroundControl

I have a brand new Pixhawk2. Initially, when connected all seemed fine. Then, all of a sudden, it just didn’t connect via USB any longer to either Mission Planner or QGroundcontrol.
Trying everything:

  • Different USB cables.
  • Different computers
  • Different SD cards
  • Re-formated SD cards
  • Tried different (old) Pixhawk which was connecting fine
  • Installed octa-8 firmware instead of quad-4 firmware and back again.
    None of this solved my problem.

Then, after installing a complete different fw, Rover, the Pixhawk was able to connect. Back to Quad-4 fw again and still working.
Summary: Don’t forget to install a complete different fw when you’re not able to connect to your Pixhawk.

Hopefully this will help any of you that might have the same issue.

Hi Tomas.
Had the same problem.
New PH2.1 will not connect to Mission Planner. PC with Win 8. Restarted Computer, instal and remove Mission Planner twice. Did try different usb ports, COM6, works with other applications.Using both Wizard and initial setup, but nothing works :frowning:
Message, No Heartbeat! or No response from board.

Happy this worked for you, but in my case it did not :frowning:

I’m using Pixhawk 2.1 and Windows 8.1 laptop.

I also had connection problem(now it is solved)

and I suspected the collision of drivers.

So I connect pixhawk and apm and go to control panel and removed its driver

and deleted mission planner and reinstalled mission planner and dont connect other device excepts pixhawk 2.1

and make sure you have to upload firmware before you press connect button on the mission planner

and are there light on the pixhawk 2.1? its usb port is little bit loose so you have to use proper cable.

and along the setup, I turned off vaccine(sometimes kaspersky block some setup in background)

and… do you still have this problem? not yet solved?