[Solved] Pixhawk 2 and HERE GNSS setup

I have recently got a Pixhawk2 and a “Here GNSS”. I am having trouble getting a lock on my GPS position. As I am quite new to this I am not sure if there is something I have missed during the setup. I simply connected the GNSS to the Pixhawk, and installed the Rover firmware.

When I power the Pixhawk, the LED’ s of the GNSS first start flashing red and blue before switching to a mode in which the LEDs flash yellow (see image below, also the round button on the here gnss is flashing red).

I tried repeating this process outside and the same LED pattern occurs. The message output of the apm_planner ground control is as follows:

[MAV 001:1] GPS 0: detected as u-blox at 115200 baud
[MAV 001:1] u-blox 0 HW: 00080000 SW: EXT CORE 3.01 (107900)

The lat, long and relative_alt are all 0

I would appreciate any help or suggestions on getting a GPS lock.



1 Like

The yellow flashes could be a few things but it’s hard to know without the specific pattern and any accompanying beep codes. See here: http://ardupilot.org/copter/docs/common-leds-pixhawk.html

I’m going to assume that it has failed pre-arm check. Have you got it connected to Mission Planner when you boot? If so, are you seeing any errors on the HUD?

Also, and I am sure you’ve tried it, have to turned it on when outside with a clear view of the sky?

1 Like

The GPS messages indicate that you clearly are detecting the GPS correctly, and that you have bidirectional communication so the wiring looks good. As @_Matt indicated the yellow led’s are a prearm check failing, and doesn’t really tell us much about the GPS at the moment.

It’s possible something on your system is creating GPS intefrence. I’d test if you get a fix if you power the autopilot with a USB cable and don’t connect the battery. (I’d try this test outside BTW)

If that doesn’t seem to be addressing anything we can move into using u-center to try and look at it in more detail, but that is a lot more complicated, so hopefully there is an obvious error that we can find before doing that.

@proficnc is there a internal fix LED anywhere on there HERE that @gpldecha could be looking at to chase down if the hardware is reporting a fix?

1 Like

can you copy all the messages that are in the message tab? not just GPS?


Thanks for all the info @WickedShell and @_Matt I managed to solve the problem. I am going to describe the steps I took to get to have a GPS lock with only the Pixhawk2 and Here GNSS. It might be very obvious to most, but I am very new to this. Hope it can be a reference for other newbies.

  1. You need to set the following parameters to 0 on the apm_planner.


These are in the advanced parameters of the apm_planner. To access them you have to go to File (top left of widget) and select “Advanced Mode”. Then go to Config/Tuning and check the all parameters button.
If this is not set and arming process is not done, the GNSS will blink yellow as described in the original post. After setting these parameters the LEDs become blue.

See video of startup. According the HUD of apm_planner there is no GPS fix achieved. This was due to be inside.

  1. You most likely have to be outside.

I placed the GNSS just outside my window and it turned green and my location showed up on the map on the apm_planner.

See video.

In this way you have have GPS location with just the pixhawk and the GNSS.

ARMING_CHECK 0 ARMING_REQUIRE 0 means you disabled all the arming checks. This is extremely risky as you have sacrificed all the checks that your system is correctly configured. Arming checks definitely wont inhibit it from finding GPS checks. I’d definetly turn these back on :slight_smile:

@WickedShell I agree on the safety issue. The arming_required does though have an effect on whether the GPS is let to lock. It seams if not armed, the GPS is not let by the system to arm.
Once I have figured out the RCMAP for my rover and got the whole loop working, I will bring saftey back into the picture. As of know the rover’s wheels are not touching the gournd :slight_smile:

It depends on the flight mode. Some require GPS to arm; others don’t.

Edit: I just realised you’re using it on rover – I am not sure what its requirements are.