[SOLVED] Mission Planner Simulation: An error has occurred

When I try to run Mission Planner’s built-in simulation (currently I want the plane sitl but this problem occurs for each vehicle), I get an error starting with the following:

An error has occurred
Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: T. Path ‘ArduCopter.frames.IrisRos.external’, line 109, position 28.

Complete error message is shown in the screenshot below.

I appreciate any help, thanks in advance.

This happened to me today as well. Updating to the most recent MP beta fixed the issue.


as @manavgandhi17 mentioned, Updating Mission Planner with the Beta Updates option enabled (Config -> Planner -> Beta Updates checkbox) solved the issue.

Negativo, la ultima version beta produce otros errores y no realiza la simulacion de un vuelo.

Hello Alperen, how did you solve this problem ?
I also faced with the same problem but could not find a solution.
If you know the solution please share with me.