[solved] MagFit missing scipy

I’m trying to run MagFit on a RPI 4 (Latest Raspian OS/Bullseye).

I keep getting an error “No Module named ‘scipy’”. I’ve tried running Magfit_WMM.PY and also via MAVExplorer.py and both give the same error and I don’t get the MagFit outputs.

The install of MavProxy is the latest and I’ve run the update as per the wiki. Any idea how I can get this working or find the missing file?

pip3 install scipy --user

1 Like

Thanks! That solved the first problem.

And then that got me to the issues with NumPy. So for future reference if anyone else runs into the same issue here are the next steps I did:

pip3 install numpy --upgrade
pip3 install tables --upgrade
sudo apt-get install libatlas-base-dev

I tried a few other NumPy related bumbling before I got to this point. I don’t think any of that helped so this should be everything needed.

MagFit will work on a RPI4, but from the bit of playing I’ve just done, keep the number of points (reduce) low and don’t be in a hurry.