[SOLVED] Lua script : cannot delete script, File Not Found

I am playing with Lua scripts in order to design some bench tests for my drone.
I just had a problem on a Cube Black with AC 4.2.2: after loading a script, the cube reported an error because it did not have enough memory to load the script.
I tried to delete the script but I get this message :

As you can see, my Lua file had a “é” letter in it, interpreted on MavFTP as “é”. Could this cause the problem ?

I changed the Log_buf_size and checked the IMU_MASK.
params in order to allow a bit more memory on SCR. The script could run on the next reboot however I still cannot delete it.
I can upload and delete other scripts.
I tried resetting params to default, flashing a brand new firmware, nothing changes.

Any help would be appreciated !

The special character is likely the problem. Remove the SD card and use a computer to delete the file.

1 Like

Thank you for the quick reply.
Accessing the SD card is quite the trouble on this particular drone, since it’s enclosed and difficult to access.
If this is the only solution, guess I will do it, but just in case , would you have any other access to the file to delete it ?

I can’t think of a different solution.

Haha oh gosh I regret building a drone with 32 screws on the top plate …
Thanks Yuri, i will see if it works in 20-30min

I suppose you could try different GCS software like QGroundControl or a CLI like MAVProxy, but learning a new GCS just to delete one file could take just as long…

Alrght, drone disassembled, file deleted on sd card, drone ready to test some more scripts !

Topic marked as Solved :+1: