[SOLVED] Logging issue, no logs generated. SD Card contains symbols in filenames

I’ve been having some trouble getting my pixhawk to produce logs. When attempting to download via mavlink, i get “no logs to download” if I remove the SD card and have a look, it’s produced files, some with a large filesize, but they’re all symbols. Screenshot below.

-I’ve confirmed SD card is good by formatting, using briefly with card reader and on my phone to add and recover various files.
-Tried ‘clear logs’ from log downloader without success
-Tried reflashing to 3.1.5 and using setup erase, and reflashing to 3.3
-Confirmed parameter set correctly in parameter list.

Wondering if anyone can provide any insight! Thanks for having a look!

Quick update here. I removed the sdcard I’d been using in my phone and switched it with the kingston that came with the pixhawk. Appear to be logging fine now. Will update after a few test flights within the hour to confirm if resolved.

I got the same behaviour with chinese pixhawk sd card… My solution is to get rid of chinese sd card and buy real ones !


Confirmed faulty SD care. Issue resolved.