[SOLVED] Landing Speed Issues

I want to preface by saying that I’ve been using Ardupilot for 11 years and have never encountered a problem like this. Since switching from a black cube to an orange cube with FW 4.5.4, my 10 kg empty-weight copter lands too hard for my liking and does not respond to parameter changes.

Firstly, it doesn’t remain in loiter despite the RTL_LOITER_TIME command set to 5000 and LAND_ALT_LOW set to 1000 but descends directly. I typically use LAND_SPEED 40, but I have tried 30, 25, and 20 with no change. Lastly, I tried setting the EK3_GND_EFF_DZ parameter to 0.5, 1, 2, 4, and 6 without significant changes.

Another dangerous issue for me is that it no longer disarms the motors automatically as it did before. I now have to switch to stabilize mode or use a switch.

Thanks for your help


you need to remove the password on the log file.

I think it’s okay now. Thanks

Slightly unrelated, but I think you should set:

I can see what you mean, in those RTLs and LAND segments the descent rate goes to -120 and does not change at the 10m altitude mark to -15cm/s
In the LAND mode the copter pauses at the 10m mark but then continues at -120.

Before we call it a bug, can you disable your rangefinder and retest, as it’s giving unrealistic readings that dont match the baro or GPS altitudes.
You’ll have to investigate what your rangefinder is doing.

Thank you Xfacta, for the time you have dedicated to me. The Rangefinder is pointed forward and is set (if I haven’t made any mistakes) just to give me the distance from any obstacles since I don’t have a front camera. I will try to disable it and do more tests.

Maybe this is my mistake, I haven’t set the parameter RNGFND1_ORIENT to 0.

Yeah if the orientation was set as Forward I wouldnt have brought it up :slight_smile:


Now during landing, everything works as it should. I only have a display issue with the distance on the rangefinder, but it’s not important. Thank you, xfacta."