Servers by jDrones

[SOLVED] FX-79 VTOL, after transition I have no controle in FBWA


(Robert) #1

Hi, I am new on this forum.
I have searched on google an different forums an did`t find solution.

I have Zeta Fx-79 buffalo converted to VTOL and Quad part works great.
I have one FX-79 only as normal flying wing witch works great to but now I have a problem to combine both together.

Scenario is:
I start VTOL and fly on a safe height ~100m and I switch to FBWA and give it full throttle.
Transition seems perfect but when “Q” motors stops plane stars to go down in 10-15deg angle and I have no control of the plane only throttle seems to work. I have pulled full elevator and there is no reaction. Then I switch to QLOITER and it is saves me that I don`t crash. I can not find where problem is.

If it is here someone who can help me I would be very grateful because I am loosing my mind.

Here is my setup file if someone see someone can see where the problem is:
FX79_VTOL_WingTesting.param (16.5 KB)

Thank you for any possible help to point me to the right direction.

Kind regards, Robert.


(Lau Yan Han) #2

Hi Robert, a few comments:

  • Did you try powering on your plane on the ground (with all props removed, of course) and test the fixed-wing control surfaces to see if they respond? If they don’t then it’s probably a connection or servo problem.
  • If you have a .bin log of your test flight, look through it to see whether there is any elevator response when you pull on the sticks. If there is, it may be that the controls are working but it isn’t responding quickly enough, which would point to a PID tuning issue.
  • Also, posting the .bin log here would be very helpful.
  • The issue where your plane noses down seems vaguely similar to a problem that I experienced in the past, where our quadplane would lose a lot of altitude when transitioning from VTOL to fixed-wing. We opened a discussion thread previously here, but have yet to solve the problem.

(Robert) #3

Hi,

First thing that I must point out is that Transition is going in strait line and level.

I have started this project:

  1. I made FX-79 as a normal plane and tuned it and all things was very easy and strait forward.
  2. I made a new FX-79 as VTOL and tune quad part, there was nothing special also.
  3. To combine both together I obviously need some expert help.

Every thing was tested on the ground without props on and all seems to work correctly. When I switch to FBWA I can see gyros correcting movements. I have put camera on the air frame to see what`s really going on with ailerons. They put small amount of down elevator to point nose towards the ground at the certain angle and there is no response on the RC command what so ever. the only way to recover is to put it to QLOITER and it is recovered at once (I love how this work it is almost insane).

Yesterday I have reset autopilot and load setup from FX-79 plane setup (not VTOL) that I was testing on the other model where all is tuned. Than I activated “Q” parameter and set all Q parameter from last VTOL setup.
Now the PID-s for plane part are from tuned FX-79 plane that is flying great. (On previous VTOL setup there was default values for plane part and did not work.)
Conclusion is that there is still the same problem as on previous setup. I am missing something here but I can not figure it out.
Here is the last log file from yesterday. Do not mind the second drop because I was showing a friend how it is recovered from fall with QLOTER.
https://drive.google.com/file/d/1HZg9bLsbFQfmHzbqv3w_FH6ka90il4GE/view?usp=sharing

I will be grateful for any help or clue on how to proceed.
Kind regards, Robert.


(Lau Yan Han) #4

Hi Robert,

That’s good to hear, I assume your tests also include checking whether the servos are responding in the correct directions?

The reason I ask this is because in the flight log (see screenshot below), the directions of your RC elevator input (RCIN.C2) and resulting output (RCOU.C2) are in opposite directions. From your param file, the SERVO2_REVERSED parameter is also set to 1. Maybe that was intentional, but you should make sure the elevator is responding to your RC stick inputs and FBWA stabilization in the correct direction.

If the servos are moving correctly, then the other possibility is that the aircraft is responding to the RC command but not quickly enough. From the log, the RC output is changing very slowly despite the RC input being maxed out at 2000. The good news is that the plane IS responding and trying to correct the negative pitch, seeing that the desired pitch (CTun.NavPitch) is increasing to counteract the decrease in actual pitch (CTun.Pitch).

TLDR your plane is responding but very sluggishly, and not enough to recover from the pitch-down.

Correct me if I am wrong, but I believe that with the additional weight and drag from the VTOL components, the optimal PID values will be different from that of a pure fixed-wing setup. Therefore it is not enough to just copy the PID values over from the fixed-wing FX-79; additional tuning would be needed.

I know what I have said so far may not be much but it’s the best I can do for now. Look forward to some good news from you!


(Robert) #5

HI,
I have tested RC control direction and Gyro correction direction also and all looks correct for the elevator and aileron.
When I tested FBWA on the ground and I tilt plane like ~10deg nose down gyros respond with up elevator (7mm up). With some reason in the air things are not working like that.
Servo 2 is reversed that it is working in the correct direction (this is the same as on the normal plane that is flying OK)
I know that PID will be different because of the 1.7kg difference (plane is 2.1kg and the VTOL is 3.8kg) I just tried them because I think when you have setup that it is proven to work, Change only things that are necessarily and later on adapt other parameters.

I must point out that PID before this last AP reset (2 days ago) I had setup made from scratch and PID-s wore default and the same thing happened.
Here is the Wing cam in the flight:
https://drive.google.com/file/d/1SxLf6e-c8tSV21JBoUadr7hh5nrhPVd2/view?usp=sharing
Here is the video from MP:
https://drive.google.com/file/d/1n4IPKyfKIVipHj39kGqdEkxY58O6TK2D/view?usp=sharing

I am grateful for any help I can get :slight_smile:


(Lau Yan Han) #6

Hi,

Sorry I was really busy with my own projects the last few days so I had no time to reply. Are you still facing issues with this?

To be honest I am running out of ideas too; I tried to look at how the power supplied to your servos are affected during FBWA but there seems to be no issues judging from your log.

Greg has also made a FX-79 quadplane conversion here (FX-79 Buffalo QuadPlane Conversion) so you might want to refer to him for assistance if you are still facing trouble.

All the best!


(Robert) #7

HI.

My problem with transition is solved!
I hope this helps someone else :slight_smile:

Solution was in parameter “PTCH2SRV_P” def value was 0.6 and I have first raised it to 1.0 and things started to work and at the end the value of 1.2 shoved perfect results.

disgruntled-patzer thank you for all your time to try to help me with my problem.

Kind regards, Robi.