[Solved] FrSky D8R XP Telemetry to Pixhawk 1

I’m setting up my new RadioMaster TX16S so I’ve been setting up a few different receivers to connect with my various flight controllers. I’ve had good success until I came to a couple of my older builds using the original Pixhawk and FrSky D8R XP receiver. I’ve attached an inverter cable to the telemetry pins on the side of the receiver and connected that to serial 4/5 on the Pixhawk. But I have no idea what protocol or options to set the serial port to. I’ve tried a few of the more common options such as protocol 10, options 7 without luck. Any suggestions? I have ordered a newer receiver in case I can’t work it out.

You want to set it tooption 3 Frsky D
FrSky Telemetry — Copter documentation

I did try option 3 to select Frisky D protocol. But I had the cable plugged in to the wrong pins on the side of the receiver. I corrected that and I noticed that in the Telemetry page of the RadioMaster there were a lot of new sensors. But they don’t display with the yaapu script. I think the protocol might be too old for the script. I’ll check that. But I have a couple more FrSky X8R receivers on order and I have them working well on other builds so it’s probably best if I just use those.

yes the yapuu script is for frsky X receivers in pass-through mode.