Solved - Flight Modes Drop Down Menus Not Displaying

The issue I was having below pertaining to drop-down menus not displaying was resolved by downloading and running a previous version (v 1.3.7.4) of Mission Planner. I was running (as recommended) the latest version by “Download the latest Mission Planner installer from here” link on site. This version did not work with the latest Arducopter 4.1 version for me. I instead had to go to “Mission Planner Advanced Installation” and then clicking on the link provided in " You can find all the different versions of Mission Planner zip (and MSI) files here. It makes sense to me that you would need to have the correct version of Mission Planner running with the version of Arducopter firmware on your autopilot, however, I have not yet observed any documentation that says, for example, “with Arducopter v4.1.0 you need to use Mission Planner 1.3.74.” Instead, the Mission Planner site recommends “always using the latest version of Mission Planner” and “Download the latest Mission Planner Installer from here.” In my case, the latest version of Mission Planner did not work with the latest version of Ardcopter.

NOW RESOLVED ISSUE WAS: Drop down menus are not displaying in flight Mode Tab of Mission Planner. Have accomplished CNTRL + F and Regen Param with no success. Same results.
Have updated to latest Beta version of Mission Planner (per another person’s suggestion). Same result.

Have cleared cache. Have cleaned hard drive.

Have tried on different computer with same result

Running Copter v 4.1 on autopilot (flight controller). Attached is screen shot with version of MP I’m currently on. Windows 10 on computer(s)

Any other suggestions? Thank you.

Hi,

I have the same issue. How to solve it?

Thanks

Hello, after hours of unluck, Back to V1.3.74: every thing workink!!

1 Like

Go to the help page and do a beta update. That is what the “latest version of Mission Planner” really means.

I know it’s confusing to need a beta version of software to achieve success, but that’s the reality at present.

If what @Yuri_Rage suggested doesn’t do it (it usually does) do you have a FRAME_CLASS set? Do you see this in the messages screen?
11/24/2021 11:54:23 AM : Frame: UNSUPPORTED

If so the Flight Modes, and other things, won’t appear.
There is pretty much never a reason to revert back to a previous MP version. Something else will inevitably be wrong.