Servers by jDrones

[SOLVED] Flight Mode Setup process


(mpjf01) #1

I imagine that this matter has been already mentioned but in a scan through the topics here I don’t see it yet. When you are setting up Flight Modes and elect for one of them to be Auto this appears in the FM ladder OK but when you switch to it to check it the FM changes to RTL rather than Auto. Perhaps this is to prevent selection of Auto while on the ground or maybe for some other reason that didn’t exist in all previous firmwares. It would be nice if there was a way to confirm that the FM that would be used when requested in flight was Auto and not RTL, is it possible to find this out somehow?


(Sebastian Schürmann) #2

If you did not upload a mission to your vehicle, auto mode will switch to rtl, because there is nothing to do for auto mode.


(mpjf01) #3

It’s on the ground, it can’t RTL either, and (fortunately) won’t try to. My point is the question, is there a way to confirm that Auto has “stuck” as the feedback suggests that it has not?


(Colin) #4

No mission no way points no go
and i think it has to move from home position before it works to


(Sebastian Schürmann) #5

I thought the solution would be obvious. Just upload a short mission and switch to auto mode, then you will see if it switches to auto or not.
Of course it will not try to RTL, because you were smart enough not to arm your vehicle, before switching through the flightmodes.


(peterbarker) #6

I imagine that this matter has been already mentioned but in a scan through
the topics here I don’t see it yet. When you are setting up Flight Modes and
elect for one of them to be Auto this appears in the FM ladder OK but when
you switch to it to check it the FM changes to RTL rather than Auto. Perhaps

Try uploading a waypoint or two?

You may also have some failsafe active…


(mpjf01) #7

I have been using Ardupilot versions on planes and multis since 2012 so I do have some understanding of the RTL and mission requirements, that is not the point of my post. I have set up many new aircraft, some of them multiple times through several firmware versions and I cannot recall noticing this behaviour until I upgraded to the 3.8 stream for the first time today. So to me it seemed like a change and I was wondering the purpose.


(MagicRuB) #8

@mpjf01 You still haven’t answered the question: Have you uploaded a mission? If you’ve reached the end of a mission, it will always switch to RTL. Having no mission is treated as reaching the end.

And, as usual, please post a log so we can stop guessing.


(mpjf01) #9

No, I haven’t uploaded a mission. The aircraft is still under construction and I’m still setting up the Pixhawk ready for it’s first test flight. There are many steps to go in the process of test flying and tuning before I worry about flying missions.

Once again you miss my point. Users following the logical process of setting up a FC for the first time - a procedure laid down in the documentation - would not be concerned about missions when choosing and allocating their FMs for the first time and wanting to check whether or not their transmitter switch/mixing arrangements were working as required. I have been through this process many times over the past 5 years and have not noticed this behaviour before and was asking what the reason for the change (if there’s actually been one) is, that is all.


(MagicRuB) #10

This is expected behavior and has always been this way. If AUTO mode does not know what to do for any reason it always switch to RTL mode as a failsafe.

I don’t see this behavior changing unless there is a very good reason. Simply doing a system test without a mission and wondering why AUTO isn’t working is not a good reason.

if you look in your messages area, the message “Aircraft in auto without a running mission” is appearing.