[SOLVED] Differential Spoiler loses SERVOxx_TRIM to 0

I have setup a differential spoilers/elevons in a flying Wing with 4 servos (2 servos per wing)

Sometimes I boot the model an all SERVOxx_TRIM for the 4 channels of the servos that are in differential spoiler assume value 0.

All other SERVOxx_TRIM for the other servo outputs had no change keeping the 1500 value.

I had many times reproduced this error and after correcting the 4 values to 1500 all runs OK.

Could you upload your full parameters or a DF log file? I’d like to try to reproduce this.

This is a parameter file after the error occurred.
If I restore Servo Trim 1,2,10 to 1500. after some reboots I they write them back to 0.

DiffSpoil.param (14.2 KB)

I have reflashed it with arducopter and then arduplane but the issue continues.
I notice that servo9_trim is saved, but 1,2 and 10 are lost to 0.

I’ve reproduced the problem, and it is caused by the parameter TRIM_RC_AT_START. That defaults to off, but was enabled in your parameters.
There is a bug in the handling of this parameter.
If you set TRIM_RC_AT_START to 0 then it will fix the issue for you.

TRIM_RC_AT_START is not yet documented and I don’t have info over it, but I can confirm that it solved that issue.
I have rebooted the board and didn’t lose the servoxx_trim values. GREAT!

In this model I reported another thread “Servo jitters in stabilize and FBWA” that isn’t has important but is a odd behavior.

Thank you Tridge

ping @mday299 since he added TRIM_RC_AT_START

TRIM_RC_AT_START has been removed from Plane in v3.8.1