[solved]Defective Qio-Tek ASP5033 CAN Airspeed Sensor

I bought two of these airspeed sensors some time ago. Unfortunately one of them is not recognized on the CAN bus, it just flashes fast and is not recognized as a node by the missionplanner, airspeed sensor and compass are logically not recognized either.

The second sensor works fine on the same flightcontroller (h743 wlite) with identical parameters and connected to the same cable. Therefore I am sure that the error is not due to the parameters or the cable.

Is there any way to reach the device electronically and fix the error or do I have to exchange it ?


I have one product from Qiotek that the CAN transiver chip is not being soldered correctly. so the CAN module communication is totally lost. This is just my case of course. you can actually see yours or attach it here. by the way, I got replacement for free.

1 Like

Thanks @Sitha_Sek for the quick information. Let’s see what @timtuxworth thinks.


1 Like

Hello, Could you contact the sales@qio-tek.com please, attached pictures or videos, the customer service will contact you to assistance or exchange. @Rolf


Thank a lot for the quick support. I will send the infos to the customer service as soon as possible.


1 Like

I’ve had one or two minor issues with Qiotec and can state from experience that their customer support and responsivness is outstanding.

1 Like

The problem is solved. Both devices work. I was simply too stupid to recognize the insufficient power supply via USB (while building and parameterizing a new aircraft) as the source of the error. One of the two devices still works on 4.5 volts of the matek h743 on the USB port of a laptop, the other device mostly does not. This is of course not a Qiotek defect, but mine :rofl: . With proper power from the battery, both work fine. Thanks @Qiotek and @timtuxworth for the quick support offer.

1 Like

I’m glad to hear that, the non redundant FCs might some strange issues, they are compatible with firmware, but may not achieve reliability long-running. If the vehicle expensive, I suggest you use redundant flight controller. @Rolf

1 Like

I am attempting to configure my Matek F743-Wing FC with a Mate GNSS M8Q-CAN, UAVCAN & MSP and QioTek CAN Airspeed sensor.

Wiring is according to the Matek diagram (http://www.mateksys.com/?portfolio=m8q-can#tab-id-4). FC ↔ Matek GPS (CAN) ↔ Qiotek airspeed (I2C port).

I’ve configured Arduplane according to:

UAVCAN Parameters


  • CAN_P1_DRIVER → 1


  • COMPASS_TYPEMASK → 0 (make sure UAVCAN Unchecked)


  • ARSPD_USE → 1

And have verified SLCan Mode CAN1 parameter is correct for ARSPD_TYPE =8

When I boot the FC, I can see that the Airspeed sensor is not initialized.

Any thoughts on what I am doing incorrectly?

Thank you. @Qiotek any help would be appreciated!

Hello. Aaron Aude @f4corsair

I think there are a mistake here.
Wiring is according to the Matek diagram (http://www.mateksys.com/?portfolio=m8q-can#tab-id-4). FC ↔ Matek GPS (CAN) ↔ Qiotek airspeed (I2C port).

Matek diagram told you is a I2C airspeed sensor wiring, not a CAN sensor, So you should rewiring with the airspeed sensor CAN port to the FC CAN port. or you can use a CAN splitter to do the connecting.

Due to the Qiotek CAN sensor built-in a CAN periph board like the Matek CAN GPS, So you can’t connect with the Qiotek CAN sensor I2C port to Matek CAN GPS I2C port directly.

Even if they are connected as you said. Because the Matek CAN GPS periph board haven’t the ASP5033 driver on it’s default built, it also can’t detect the Qiotek ASP5033 I2C sensor to works.

Thank you @Qiotek (Jason).

So here’s what I have now - FC CAN → Wire → Splitter → 1) GPS (CAN) and Splitter → 2) Qiotek Airspeed (CAN).

Both GPS and Airspeed are blinking slowly blue.

Still can’t see the Airspeed sensor, however. When I go to SLCan interface, I see 4 IDs, but none of them are airspeed. Further, Airspeed does not initialize.


Can you see the f103-qiotekperiph board name in the IDs list? and check the Matek FC board with the battery power applied. @f4corsair

No - it is not in the list. I am testing this with power from a flight pack battery, not USB. Thanks @Qiotek

Strange, it should be in the list because the LED is blinking slowly blue which means CAN communication has been handclasped. @f4corsair

Agreed - I will remove the Matek GPS from the splitter leaving only the Airspeed sensor and then look for the board name ID in the list. I will paste the screen to this message a little later this afternoon ET. @Qiotek

What is the correct value for ARSP_TYPE?

UPDATE - I continue to observe the Error: Airspeed 1 not initialized, cannot cal despite the following settings:

In CAN1 Configuration for the Airspeed sensor I have ARSP_TYPE as 1, 3, 6, 8 and 9. I then reboot the plane and observe the messages in Mission Planner as the FC initializes. Each time, the error show above appears.

Curious @Qiotek if you have any thoughts on this?

@f4corsair CAN1 Configuration for the Airspeed sensor ARSP_TYPE to 15 and the ARSP_TYPE of FC set to 8

Thank you Jason (@Qiotek). I am becoming more confused each time I try to resolve this.

Now - when I connect to CAN through Mission Planner, I see the Matek GPS, but when I attempt to look at the parameters, the dialog window is blank.

If I have the GPS and Airspeed both connected in a CAN splitter (FC → Splitter) and a wire to GPS and another wire from splitter to Airspeed.

Confused because when I click on MAVLInk-CAN1, I see the list of IDs, but only the first has a name. The others are ?

All I want to do is connect my Airspeed sensor to this FC - so curious if there is an easier way??

Quick update - I had success yesterday with both the GPS and Airspeed sensor. Here’s what I did:

  1. Remove GPS from splitter so that FC and Airspeed sensor are the only devices communicating.
  2. Open Mission Planner and look at MAVLink CAN1 connection. Airspeed sensor is given name (vs. ID with ?).
  3. Click on Menu and select parameters
  4. Set ARSP_TYPE to 15
  5. Save parameter
  6. Remove power from FC (battery) to force a hard restart
  7. Observe airspeed functionality in message, status and main UI of Mission planner.
  8. Reconnect GPS to splitter
  9. Remove power from FC (battery) to force hard restart
  10. Observe GPS functionality

Thank you Jason and team @Qiotek for your help with this. I suspect my issue here has been the ‘soft’ reboot (via compas) vs. ‘hard’ reboot (via power removal).

1 Like

Usually, users only need to set the ARSP_Type of FC to 15, then restart FC, and can use it normally. The issue you encounter may be caused by setting the default parameters of the AP_periph board you changed. @f4corsair