***SOLVED*** Copter 3.5 loading

Sorry for the new beginner question. I have searched and am unable to find a simple way to load 3.5 on the Cube. I doesn’t come up in Mission Planner even when i click “load beta firmware”. I am sure it is right in front of me, but can’t seem to find it. Not sure how to proceed? I have down loaded 3.5 rc3 from releases; just don’t know how to get it on there.
Thank you in advance!

Hi Randy,

Have you looked at our guide in the wiki? The images may be a bit outdated (although they look alright to me), but you should be able to follow this to install Copter 3.5 - just remember to press the Beta firmwares button when you get to that screen. Then choose what frame configuration you have and MP should guide you through it.

Hi Oxinarf,

Thank you for the quick reply. Yes I have read the wiki a number of times to try see if I am missing something.
I just tried it again and all the copters are listed with V3.4.6 . The only other words there are "Please click images above for flight versions. Ardupilot is free software. Click here to read the open source firmware.

I tried to connect just for fun and it gave me a warning that it could not load firmware while connected. BUT when I disconnected for a brief moment I saw “Load Beta Firmware” and another something below that. So it appears and disappears quickly for some reason. I uninstalled Mission Planner and reinstalled it, but can not figure what I am doing wrong?

Thank you for taking the time to read!

Just tried it again and it now says, " Force PX4 Boot Loader" in the area where the I saw the beta firmware briefly while connecting and disconnecting.

Thank you!

I’m not sure what is going on there then. I recommend you open a topic in the Mission Planner category or open an issue in Github (http://github.com/ArduPilot/MissionPlanner/issues).

Thank you Francisco!

hello did you get version 3.5.0 back for pixhawk cube?
Can you help me if you could do that?