SOLVED Can't throttle down! Did I set something wrong?

I had an interesting maiden flight yesterday. My brand new Sonicmodell Binary running ArduPlane 4.2.2 on a Zealot H743 took off great and flew nicely, but just wouldn’t throttle down below maybe about 40%. I had set a ARSPD_FBW_MIN to 9 m/s because this plane is notorious for stalling, so I didn’t want it going too slow, but the plane was definitely going faster than that and I couldn’t slow it down and I really couldn’t bring it down.

Throttle on min - the plane was still flying 20 m/s and higher and just wouldn’t go slower. At first I just flew around in circles trying to figure out what to do (and maybe drain the battery as the only way to get it down?) I eventually switched to manual and managed to land.

Solution: Thanks to @Allister - the plane had fence breach/failsafed and had switched to RTL mode. I thought I had switched back to FBWA, but actually I hadn’t! It was still in RTL the whole time, so it was flying around in circles at RTL at TRIM_THROTTLE (as it should) and pretty much ignoring me.

Here’s the log - any suggestions for what I should change?

So far I’m faced with some confusing information. Specifically:
I have TRIM_ARSPD_CD = 1500 (or 15m/s) and it sure looks like this might be the minimum speed the plane is trying to fly, but I have ARSPD_USE = 0, so this parameter should be ignored as far as I can see according to the documentation.
I have TRIM_THROTTLE = 45 and it does look like the throttle won’t go below about 45%, but I though this was the “mid stick” speed, not the minimum speed - again as per the docs:

Without an Airspeed Sensor

Without an airspeed sensor, both the pitch trim and the TRIM_THROTTLE parameter would need to be changed appropriately for the desired mid-stick cruise speed.

I think you’re fighting another problem. The plane kept breaching the geofence, and switching to RTL. You were able to control it because luckily stick mixing was on. The throttle would go back up because the plane was trying to climb back to the RTL height. Given the fight you were having between RTL/FBWA, I’m not able to sort out the speed issue. You might need to adjust your geofence for such a fast plane or keep the radius in mind as you’re going.

A little off topic, but how are you sourcing your Zealot boards? Their website is slow and almost unresponsive, and I can’t even add anything to the “cart!”

I have a reseller deal with Jason. You can buy them from (me) and I will have them drop-shipped to you. Only the H743 for now and a couple of peripherals. If you want anything else let me know.

1 Like

Thanks for looking at it @Allister . Please look at the end of the log, after I figured out the RTL thing, I just flew it around in circles in FBWA (no RTL) for about 5 minutes before I switched to manual and “landed”. I had also hit my “throttle cut” on the Tx by that time to try to slow it down, so RC3 was sending 986 flatline but throttle wouldn’t go to below about 45%.

Due to a glitch with my Go-Pro I don’t have footage, but this last 5 minutes is me just flying around and around circles in FBWA burning off the battery. Yes I didn’t switch the throttle back on until I went into manual mode. This part is useful though, because I know the throttle is working correctly. Afterwards I did a re-cal on the RC and nothing changed from what you see in this log.

But still - why would FBWA be just flying at 16 m/s (pretty consistent) with throttle at 45% upwind and %100 downwind?

There’s the entire flight. The bulk of the flight was in RTL.

Thanks. That explains an awful lot. I think the display was confusing me. This is what I see which seems to show it switching into FBWA model at around 10 minutes in.

But if I zoom in, I can see that it actually switched to RTL, so OF COURSE it was doing that. I appreciate the help and now I’m ready for my next flight (after I fix the landing gear).

1 Like

I really like the online log analysis tool for broad looks at data and its well-done map.

But for more detailed analysis, I usually turn to Mission Planner. Arguably, MAVExplorer is a better tool, but I find it a bit fiddly.

Yeah - but I haven’t (yet) been able to get MAVExplorer to work on my Mac. I guess I should look at that!

Mission Planner for log analysis is hopeless on the Mac. The screen is weird and some of the buttons and other fields display outside the window so you can’t click them.

MavExplorer is my go-to now. I’ll admit it is a bit fiddly to get started but once you get the work flow its worth it.


Yeah - I’m good with the whole cli interface thing. It’s just some kind of python issue I think. I have MavProxy (with maps and OSD) working so it should be possible with MAVExplorer.

I’ve been trying MavProxy more lately. I haven’t flown with it yet, but I’ve been using it for downloading logs and doing quick parameter changes on the bench. One day I’ll get around to flying with it.

I’m surprised that MavProxy is working, but MavExplorer isn’t. My Mac is the the only computer I haven’t installed it on so I’ll give it a try some day.

1 Like

Oh you can download logs with MavProxy? I’ll have to try that! I’m mostly using it for SITL, but also trying to set it up to forward telemetry to an antenna tracker.

Yes me too - I’m sure it’s something simple. It was painful to get MavProxy working, but I think all the big issues are solved.

From the Mav> prompt:

log list
log download [log file number]

I’ve only figured out how to do one log at a time, but often in the field that’s all I want. The download takes the same amount of time, but I find I can initiate the download right away compared to MP that needs to setup first.

And if you start MavProxy in the directory you for that aircraft the download goes to the right place right away.