[Solved] Bad altitude hold with 3.4-rc5

Hi, I have strange altutide hold behavior with 3.4-rc5. (genuine pixracer, ZMR250, 4S, 2204 motors, 5045 props, ~20% hover throttle).

With sticks at 50%, the copter moves up/down by 2-3 meters.

(i have other issues, like compass not calibrated after restart; ekf anomalies; but those are already reported on other topics.)

Here are my logs and the full param list:

Can you please help? I cant use any of the modes like this, except stabilize and acro. Would be nice to have a reliable RTL/Land and AltHold.


There must be something strange with your setup. Although I+m not using 4S batteries my small PixRacer quad behaves fantastically in all modes. I’m using 2204-2300kV with 6040 propellers on 3SRobocat parameter 9-10-2016.param.zip (4.0 KB)

I’m attaching my parameters ONLY to serve as guidance.

Flight performance is quite reasonable, although I haven’t done auto-tune. These videos were made mostly on either Stab or AltHold, with brief excursions to PosHold.

The Throw tests were done also but the GoPro battery was dead :slight_smile:

Hi, thanks for the params, im going to compare them. Im using hand calibrated PIDs.
Good to hear this should work.
I moved from 3s because my quad is quite heavy (around 700g with batt) and i wanted a bit more power. I had good results with alt hold on 4.3-rc 2-3 but had other issues.
Thanks again :slight_smile:

The Quad you see on the videos and is using those parameters is 635g with 3S 2200mAh 45C NanoTech batteries

And Emergency Stop works :slight_smile:

Just finished watching the videos, awesome :slight_smile:
I currently comparing the params,
Do you really have MOT_THST_HOVER at 0,13100241? With 6040 on 3S?
Mine is set to 0.25, because the docs says thats the minimum

Beside of this, i dont find any other major difference. Did you use hover auto learn?

I was surprised with that too, but Hover auto learn is always “on” :slight_smile:

I will try to set it to 0.19, that would be my ‘good’ value with 5045 (gemfan).
But i have to be careful, because if it resets to default, 0.5, the quad will just disappear in a moment. :smiley: My biggest fear is that is flies away, uncontrollably.

Indeed, you have hov.learn enabled, was yet hiding between the other params

Just set one switch to RTL and don’t be afraid to use it :slight_smile:

On my radio I have a 3 position switch that goes RTL and Land on each position, so that I can be “courageous” with settings (and I have also a switch for Emergency Stop :slight_smile: )

@LuisVale: just finished testing the hover learn, resulted in: MOT_THST_HOVER 0,1962113
The quad flies great! Thank you for your suggestions and pointing me to the right direction.

Sooo, as for a TL;DR:
an overpowered mini quad can fly well; enable hover learn confidently, take off slowly for first.
The min-max values are not enforced for this. I’m flying fine with 0.196…

Glad I could help. Now at 0.13 my quad goes faster than yours :slight_smile: