[SOLVED] Auto take off doesn’t activate the motor

After upgrading from 3.7.1 to 3.8.5 or 3.8.4 (tried both) the auto takeoff doesn’t seem to turn on the motor. My setup is a large heavy composite UAV so I am not willing to launch it from the catapult without being sure that the motor will turn on. When I had the 3.7.1 I used to put the TKOFF_THR_MINACC to 10 and then pull the airframe suddenly to simulate the launch and the motor would turn on every time. Now it doesn’t do anything. I don’t want to go back to 3.7.1 as the migration will consume a lot of time.
Any ideas ?
Hardware Pixhawk 2.1 AKA CUBE. Dual HERE gps and airspeed sensor.

(Also tried many combinations of this 5 parameters…)

I think it’s a classic problem when moving to 3.8.x
Does your motor spin after arming in manual or fbwa ? Does esc initialize (bip sequence)?
If not you have to adjust servo3_min/trim/max and rc3_min/trim/max to match same values. Replace servo3/rc3 by your motor(s) output.

ESC initialization works, it spins in manual and stabilize. I will check with fbwa. It also spins in auto if
I set the throttle to passthrough.

Throttle works in FBWA. Its also always suppressed in Auto. channel 3 is set to 70: throttle

I loaded arducopter to erase all the params and then loaded arduplane 3.8.5 . The problem was solved. It seems that after migration from 3.7.1 something in the parameters that came from 3.7.1 was causing the problem.

1 Like

Interesting and afraid !
Did you reload old parameters ?

I am pretty sure that if I reload them the same problem will appear. I will use the parameter file as a reference . I will compare the new parameter file with the old one to see what is different. We need to understand what was causing the problem, I was lucky I tested it before launching the catapult, someone else might not be