Servers by jDrones

[SOLVED] ArduRover no signal to ESC and Servo [SOLVED]

arduboat
pixhawk4
(Stefan) #1

Hi everyone,

I’m new to this forum and also new to ardupilot, but i have seen this is a good community and i look forward to see more projects here.

First of all i want to explain what i want to do with my ardupilot:

we had here some Topic about TrollingMotors @rmackay9 anserwerd there some questions but a documention about how to configure ardupilot for trolling motors is still missing.
My goal is to create a complete documentation to use ardupilot to create a cheap TrollingMotor with GPS and “loiter”

All my test will be postet here: https://www.opentrollingmotor.org and videos at: https://www.youtube.com/channel/UCVDB9ST9KKrJB6ykByx-pwA

If everything is completed and working i want to make for the rover a complete documentation how to setup a trollingmotor with gps.

And now to my problem:

Pixhawk 4 is configured as Rover frame class 2 (Boat), i did the calibration of Gyro and compass successfully.
I didnt have RC who can communicate with pixhawk thats why i dont want to use RC i changed these option in config:
-FS_THR_Enabled=0
-Arming_Check=8
-BRD_Safetyenable=0

Then i was going out to get GPS to test everything, i can arm the autopilot but my ESC and the StepperController are not working properly. the ESC is beeping and StepperController has red LED.
Here you can find two videos first about the StepperController, with my RC ist working good and second video Ardupilot Armed but ESC and Stepper not working:

Stepper:


Ardupilot:

Log and Config Data:
https://www.opentrollingmotor.org/wp-content/uploads/2019/08/Ardupilot/

It looks like that i dont get signals by PWM.

I hope you guys can help me, maybe I just forget something small toodo.

Thank you very much for your help and enjoy your weekend :slight_smile:

And sorry for my bad english…

Best Regards

Stefan

1 Like
(Stefan) #2

Hi everyone,

It was like i though, just a small stupid problem:

We can see here the wrong wiring of PIX4 to the powerboard…

Here i corrected the wiring to my use case, after that the stepper motor was working, but ESC was still beeping and not working:

Today i found out that the ESC is only working when the PIX is armed and on boot up i hat to made a ESC calibration by Joystick.

Now i can start testing the how it works :wink:

1 Like
(rmackay9) #3

@DerSchakal1007,

Great that you got it worked out. We’ve got a bit of documentation on working with a Trolling motor here on the wiki.

EDIT: one small thing after reading the documentation you’ve started, it’s better to refer to the hardware as “Pixhawk ArduPilot Hardware” or alternatively just “ArduPilot compatible flight controller” and of course we have many options.

(rmackay9) #4

The stepper motors are looking good. I’ve wanted to test stepper motors with ArduPilot for BalanceBot for some time so it’s great to see it working!

(Stefan) #5

@rmackay9

I know the small part about trollingmotors under ESC and Motors documentation for Rover but this is just a small start about basics and without steering.
About my documentation, did you mean my website where I have to change the refer?

I can really recommend you the Pololu TIC stepper driver, there you can Programm everything over usb by your computer with a very nice software.

You can set the stepper motor to Servo Funktion or to motor Funktion. with so many option like acceleration speed, max Stepps (speed), for servo how many Stepps max in one direction etc… but i thing for your balance bot stuff is the motor Funktion the correct one.

What do you think about to open a extra thread under ArduRover 3.5 only for my Trolling Motor project without much bla bla. Only correct and short information what the people need for that.
Or did we change later the WIKI, when everything is working well and refer to my videos and blog posts?

Thank you in advance

Stefan

1 Like
(rmackay9) #6

@DerSchakal1007,

Thanks for the advice on the stepper motor driver.

Re the suggestion to changing the wording to “ArduPilot compatible flight controller”, yes, I was referring to https://www.opentrollingmotor.org. No pressure though, it’s not a big deal.

Feel free to open a special thread for your trolling motor project. Once you have it in the water, feel free to make a blog too (same as creating a new topic but set the “category” to “blog”).