(SOLVED) 9Ch-14Ch DO_SET_SERVO Mavlink command not working

Hi All,

Is there any current limitation that I am not aware of, for the do set servo command on channels from 9 and above? I only found a topic (See below) that might be related, from copter forum.

I know that mission planner not showing the status of these channels is a Mavlink1 limitation. However I am not talking about status, but actual control. However not mission command control, but control via mavlink.

If I use RC and send PWM on any of those channels in the s-bus stream and I can use them for control and even servo RC pass-through, Whatever I am controlling works from RC. However if I send command from mission planner or other Mavlink (DO_SET_SERVO) then nothing happens

No mater if I set servo function to 0 or to 1.

Can someone please kindly check if they all get the same results. Any channel from 9 and above. Then use command set servo on that channel. Does it register on the AP side? Can you control a servo on Ch9 with sending Do_Set_Servo and if moves the servo. Agian, I do not mean put command in mission, but to use servo control inside of MP (see picture) or other means of Mavlink message to do it.
In my case we are sending Mavlink command (buttons pressed on ground control station), over telemetry, so that is why it is not a mission command.

I am sure a lot of people do not use these channels, especially not for such functionality, so that could explain why it is not so obvious.

I found these on relating matter, I know copter gets all the love, so could be related:

Any help is appreciated.

Hey, can anyone simply confirm that they get the same results. No need to fly. Just to check on the ground.
Would only take you a couple of mins and let us all know if it is infact a flaw or if I have some settings problem.


Can you please check this for me. Everyone else is too busy.


Still hoping that someone could kindly verify my finding before I post issue on github.
Thank you.

Checked It is working with plane 3.8.2 flawlessly. Therefore you are doing something wrongly. (Perhaps not pressing the safety before testing.)

I’ve just tested it with MissionPlanner and plane 3.8.3 and it worked fine.
Perhaps you could post a tlog of it failing so I can check for unusual parameters? Please have SERIAL0_PROTOCOL=2 so the tlog shows all 16 outputs (assuming you are connecting over USB, otherwise set the appropriate SERIALn_PROTOCOL=2)
Cheers, Tridge

Thank you Tridge for taking the time to look at this. That is reassuring to here that it worked. So much by something just my end.
I shall investigate further.
BTW, using serial 1, RPI unit is sendign and receiving the telemtry and mavlink. I shall check the protocal.