[Solved] 3DR Telemetry won't work on OSX

Hey folks,

I recently started building my new hexacopter based on an APM 2.6 running the latest firmware.
So far everything works fine, except my 3DR telemetry won’t show up on my Macbook Pro, running the
latest OSX version, which should be 10.12.
My research the last two days thaught me that the driver for the FTDI chip could be a problem. Therefor I
installed and uninstalled different versions of the driver (including the newest version from the FTDI website and
that one, that came with the APM Planer 2 setup files).

At this point I definetly need some proper help. I double checked that the reciever is working on my Windows tower PC. And on Windows 10 everything works fine. And I can establish a good connection.

Do you guys have any idea, what else I can try?

Best wishes,

1 Like

Check in System Information app the USB device, and what its reporting the USB chip manufacturer to be. You may have a radio using a chip from Silicon Labs. You will need to install the appropriate driver

1 Like

Dude, you saved my day! <3

You were absolutly right. After a quick google search I follow those instructions:

And tadaa, it worked.

Thanks a lot!


nailed it, downloaded legacy acos silicon labs driver installer from silicon labs and bingo! all good. worked for ubuntu as well!