Solid red light when booting

Hi all,

This is about an official 3DR Pixhawk even though I will need to mention HKPilot device to explain my problem.

So I have two HKPilot 32 which behave quite badly, after weeks of trying to solve altitude issues I decided to use my official flawless 3DR Pixhawk from my 3DR Y6 to be sure that the problem comes from the HKPilot 32.

I removed the pixhawk from the Y6, flashed it, put the parameter file extracted from the HKPilot 32 in the pixhawk and then I forced a little bit on the picoblade plugs to connect the official pixhawk to the GPS, Hobbyking power module etc.

Everything worked just fine until I plugged the battery in. Now, the LED becomes red when it boots (please see the video below).

The pixhawk does this every time, I still can flash firmwares in it and connect with NSH but mavlink doesn’t work. Also I don’t know if it is possible to perform a full test with NSH to find out what is broken.

I measured the voltage of both HKPilot and 3DR power module, they both provide 5,3V so I don’t see what would have broken my Pixhawk.

This is the video of the pixhawk booting

Thank you in advance for any help, if you can give me info on how to perform material tests in NSH or to find out why would the HKPilot power module would have broken my 3DR pixhawk or anything usefull it would be very generous.

PS: I already formated the µSD card and used another µSD card without success.

I still can’t solve my problem, neither find the initial cause of the failure.
It is quite stressfull because I can’t try to plug another official pixhawk (the HKPilots are doing fine though).

I flashed the bootloader of my pixhawk but it didn’t change anything.
I didn’t upload the DFU file though, I may try this…
I am convinced the problem is a software problem.

If anybody has any advice it is very welcome :slight_smile:

Can you connect via NSH and typ "df " and post the output?
If that works, please take the SD card out, put it into your PC and try to find /APM/BOOT.LOG and post the content here.

Do you happen to have tried updating the bootloader or did anything else with a DFU tool?

What’s the USB id of your Pixhawk? 26ac:0010 or 26ac:0011.

Hi StephanG,

Thank you very much for your reply!

When I perform a df this is the output I get … hoto%2cpng

There are no BOOT.LOG file but the pixhawk did create the APM folder on the formated µSD card when it booted (the folder is empty).

I am a bit confused by the fact that there are no BOOT.LOG file in any flight controller I own, even the ones that are working. They are supposed to be in the APM folder in the µSD card right? There is no folder APM/LOGS in the faulty Pixhawk while the folder APM/LOGS in the working HKPilot32 contains only BIN files related to flights, no BOOT.LOG to be found.

I did upgrade the bootloader following the “upload via microSD card” from this page
I used the px4fmuv2_bl.bin, it didn’t change anything in the pixhawk behaviour.

I didn’t touch the DFU file, neither I used a DFU tool, should I try this or is it dangerous and could brick my pixhawk?

The USB ID is USB\VID_26AC&PID_011\0 (I see that in the port COM properties so I suppose the USB ID is 26ac:0011).

I just found that I can start ArduPilot from the nsh prompt, this is the result I get "Unable to open /dev/adc0" … hoto%2cpng

Thank you in advance for any help.

Stefan asked me to have a look at this issue.
The symptoms mean that the ArduPilot startup script (called rc.APM) is starting, but is not completing. I can think of two ways this could be happening given your description so far:

  1. you have a file called APM/nostart on the microSD card, which tells ArduPilot not to startup. I doubt this is the case, but I mention it as if you do then we will waste a lot of time on the next option
  2. the rc.APM is failing to start one of the key sensors, but is also failing to log the startup error in APM/BOOT.log
    To diagnose the error do this:
  3. boot on USB power only, with no microSD card inserted
  4. it should boot with the large LED solid red
  5. connect with a terminal program on the USB port. You should get a “nsh>” prompt
  6. run this command:
    sh /etc/init.d/rc.APM

You should get output something like this:

If you can capture the whole output and post it to the forum that should let us find the failure.

Hi tridge,

Thank you very much for your time, please find the output of rc.APM in the link below (copy paste doesn’t seem to work in MP) … hoto%2cpng

The error message is (so that people experiencing the same issue will find this error in Google)
[MS5611_SPI] on SPI bus 1 at 3
ms5611: interface init failed

It also shown a failure of a rm command but I suppose this is normal since the unlink failed also in the output you provided.
rm: unlink failed: No such file or directory

Thank you very much for your help.

Using the new informations, I made some researches and found this topic

I tried to start the pixhawk with the safety switch pressed, the tones told me that it reinstalled the firmware but it didn’t solve the problem. :frowning:

ok, that narrows it down to the ms5611 barometer. First repeat the test several times and make sure it is always the ms5611 that fails.
Then do this:

  1. boot to nsh as above
  2. run “uorb start”
  3. run "ms5611 -s start"
    Try that several times to see if it is intermittent or if it fails the same way every time.
    Also please try the latest firmware from to see if there is any difference in behavior.
    The most likely result is that your ms5611 is broken. You could try and debug it in detail if you want to. If I had to guess then I’d say it is failing the CRC check on the prom read. You’d need to use a debug version of the build to check that.
    This is a very unusual failure btw. Is there any chance the board has been subjected to a large over-voltage spike?

Tridge thank you for your answer.

The error is always the same.

  1. uorb is always started
    3)With the latest stable firmware, when I start the ms5611, the system gives me an error and then crashes, the error is
    ms5611: interface init failed … hoto%2cpng

With the latest firmware available on, the error is almost the same except the system doesn’t crash, the error is
ms5611: no device on bus 3 … hoto%2cpng

I wouldn’t have any reason to believe the pixhawk was subject to a large over-voltage spike but the fact that it is the barometer that seems to fail is very interesting.
I was developing a new drone and choosed to try an HKPilot32 since the pixhawk is out of stock almost everywhere.
After some flight tests, the HKPilot32 started to give altitude drifting (it could reach +/-70m in less than 5 minutes) with the drone on the ground, even if it was plugged only on the USB. I returned the HKPilot32 to Hobbyking and got another one.
At the same time I bought a Chinese pixhawk.
Both the new HKPilot32 and the Chinese Pixhawk seem to respond perfectly well when the drone is on the ground but when it flies in loiter it may start to climb very quicly, up to ~100meters in less that 5 seconds before the altitude is updated on the telemetry and then it goes down to its normal altitude (when the drone is climbing, the altitude on the telemetry stays the same).
The way it behave leave me the impression that the propellers are perturbating the barometer but the thing is the propellers are way below the flight controller now and the flight controller is protected by a box (not hermetic).
This is the reason why I took my official piwhawk from my 3DR Y6 and put it on this new drone, I wanted to see if an official pixhawk would have the same problem.

Anyway, I explained all this because during all that time, the other components were the same (GPS, power module, RC receiver), now I start to think that maybe one of these component is faulty and is perturbating the barometer somehow.
Then maybe it broke my official pixhawk because it is an older board (I bought in february 2014) and maybe the barometer got some protection against voltage peaks on newer versions of the board…

Did you hear about a faulty power module or other components that would break the flight controller?
Is there a debug build available somewhere?

Thank you again for your time and your help!

Out of curiousity: Did you do the NSH testing with the naked Pixhawk or with external stuff (GPS/compass/…) connected. If with external devices, could you try again with a naked Pixhawk?


I did all my tests with naked pixhawk and even on different computers unfortunately.

Thank you for your reply.

As Stefan suggests, trying without anything else connected is worthwhile, although I suspect it won’t change the result.
I’d also note that bad altitude readings are not always caused by the barometer, they can also be caused by bad accelerometer offsets. Plotting the raw pressure from the log can help determine which is the cause.
I have built a debug version of ArduCopter for you to try:
This version changes two things:

  1. it adds debug to the ms5611 startup, printing all prom bytes
  2. it lowers the SPI bus speed to the MS5611 from 11MHz to 5MHz
    Please try it with no microSD card inserted, and powered only on USB, with no other devices attached. You will need to run “uorb start” before you run “ms5611 -s start”

Hi tridge,

Thank you very much for your answer, I hope you do sleep sometimes :wink:

Please find the result of the output in debug below
crc failed
prom readout failed
ms5611: no device on bus 3
ms5611: driver start failed

Here you’ll find the full output with all the prom values … hoto%2cpng

Thank you also for your help on the more general issue with the barometers/accelerometers.

Hi tridge,

Thank you so much for your comment about the vibrations that causes altitude misbehaviour!

You can’t imagine how much time I lost on this issue because I was focused on the barometer!

I am on the field right now and my quad flies so well!

Unfortunately my official pixhawk is still broken and now I really don’t have a clue about what could have broken it :frowning:

Hi tridge,

Could you please have a look at my answer on June 26 above so I can know if my pixhawk definitely broken or if there is still hope to repair it?

Thank you very much in advance
Best regards

Tridge is currently caught up in fixing some important issues. I’m sure, he’ll get back to you shortly. However from what I saw so far, it looks like your ms is dead.

Hi StephanG,

Thank you for your answer… :neutral_face:

Hie All,

I am using a 3DR PX 4 in my hexacopter. My flight controller board has been working very well, until the last flight. In the last flight that i took, i was flying the copter in manual and had a hard landing due to pilot error. This caused the landing gear frame of the copter to crack, but the flight controller board was intact.
Now when i tried flying my copter again after a few repairs, i faced a few problems.
As i am powering up my copter, the flight controller board shows a bright solid red light in the main LED.
Please advice and help as in what may have happened and how do i rectify this problem.

Thanks in advance.