Slower takeoff acceleration in 4.1.0 causing unstable takeoff behavior

I just recently upgraded to ArduCopter v4.1.0 and noticed that takeoff flight behavior has changed for the worse. The initial takeoff acceleration is considerably slower, enough so that my hexacopter was exhibiting some unstable behavior as it was trying to leave the ground due to the motors not spinning fast enough yet.

I tried to match the scale of the axes as best as I could. From the looks of it, this could be related to the broader S-Curve changes in waypoint navigation behavior that was introduced in v4.1.0.

I would raise WPNAV_ACCEL_Z, but I don’t want to add more load on the motors during the ascents/descents that occur later in its mission. It’s currently at the default value of 1m/s^2 and I hope to keep it that way.

Is this a known issue? I’ve been thinking about trying to alter the codebase to add a separate vertical acceleration value that is only used for automated takeoffs. It would be better if I could make a PR for this on the actual ArduCopter github repo, so that I don’t have to make a new mod for myself each time I want to upgrade my firmware. I was also thinking that it would be nice to tie this separate takeoff acceleration value to a parameter for easier configuration.

Note: My hexacopter is very large/heavy, which might make this issue not as applicable to other users. Or maybe I’m missing something, idk.

I am experiencing very similar issues with our 75 pound hexacopter. Since going to 4.1 our auto takeoffs are really unstable with it taking a long time to get off the ground and sometimes will lean a lot before going vertical. I think the auto takeoffs have gotten worse.

Please retest with ArduCopter 4.1.5
We only fix bugs on the latest stable version.
Even if there is an issue we will not fit it on , we will fix it on 4.1.6. So please do not waist you time with non latest versions.

I have reported this error elsewhere, but the developer thinks there is no problem,
So if I don’t think it’s necessary,
It is better to continue to use version 4.0 +.

I think you are referring to a post where the solution was to increase the PSC_JERK_Z parameter to increase the acceleration change rate. If that is the case then yes it is not a software issue, it is an issue of having an incorrect parameter value set.

ArduCopter 4.1.5 is the latest stable and recommended version. And with that parameter change it will behave better than 4.0.7

1 Like

I’m sorry I didn’t find the value you said.

These are the relevant parameters:

I think you only need to change the last one.

1 Like

Thank you very much. I think this should solve my doubts. I will look for an opportunity to test it.

Update: I did a takeoff test on 4.1.5 to see if the issue is still there. For safety reasons, I used a much smaller quadcopter to trial this, and it made the difference in climb rate less pronounced (though still noticeable), but I was still able to clearly see the difference in the motor output signals. In 4.0.7, there was a high degree of unity in the RCOUTs that disappeared once upgrading to 4.1.0 and 4.1.5. This disharmony turns into actual takeoff instability on my larger hexacopter.

I’m a bit of a novice when it comes to contributing to open source projects such as this, but I was looking at the codebase and was thinking about trying to submit an Issue to the actual repo and maybe take a crack at this myself.

Any advice would is appreciated. Thank you!

Hi Matt,
Can you post a .bin log of the issue occurring, and maybe even an earlier log (4.0.7) where the issues didn’t occur ?

This might be related to Copter: fix take-off velocity limits by lthall · Pull Request #21361 · ArduPilot/ardupilot · GitHub