Skyviper will not arm

Need help figuring out what is wrong with quadcopter . Since I changed out a bad motor about 2 weeks ago weather last few days improved enough that I was able to get 3 flights in yesterday , but after charging batteries and trying for a 4th flight the quad would not arm . Flight Controler Messages on web interface say PreArm Logging failed . I tried disconnecting battery a few times hopeing error would clear , no luck .
Tried again few mins ago to get a flight in on lunch break at work, same issue will not arm . This time FCM’s are No IO ;Thread Heartbeat ; PreArm Logging Failed ; Tmode: ALT_HOLD arm Failed ; Tmode GPS arming failed ; Initialising APM (5 times with 5 sec interval time stamp) ; EKF2 IMUO tilt alignment complete ; Tmode Alt_Hold failed ; PreArm Gyros not calibrated.
No idea what to do to correct or how this happened any one have ideas or suggestions?
13:41:47 No IO Thread Heartbeat
13:42:05 PreArm: Logging failed
13:42:09 Tmode: ALT_HOLD arm failed
13:42:10 Tmode: ALT_HOLD arm failed
13:42:12 Tmode: GPS arming failed
13:42:15 PreArm: Logging failed
13:42:16 Tmode: ALT_HOLD arm failed
13:42:19 Tmode: ALT_HOLD arm failed
13:43:39 Initialising APM
13:43:44 Initialising APM
13:43:49 Initialising APM
13:43:54 Initialising APM
13:44:00 Initialising APM
13:44:02 EKF2 IMU0 tilt alignment complete
13:44:37 Tmode: ALT_HOLD arm failed
13:44:51 Tmode: ALT_HOLD arm failed
13:44:56 Tmode: ALT_HOLD arm failed
13:45:14 PreArm: Gyros not calibrated
13:45:44 PreArm: Gyros not calibrated

Personally I would connect to the Sky Viper with mission controller, set the quad on the floor and check for messages popping up in the flight data screen. You can run the calibrations in the web interface @ to make sure they’re okay. “Gyros not calibrated” sure sounds like you lack some sort of calibration that is part of the Pre-Arm safety check. More info @ Also, after changing motors, make sure they’re spinning like the other ones with the motor tests and re-calibrate the magnetometer-motor interference.

Try doing the calibration steps in this video

Thank you for the advice was about to try calibrating steps as suggested . When I powering on drone I decided to make sure SD card was in place, by ejecting and reclining it back. Powered up connected. Like magic only msg was fence needed parameters. It then got solid gps lock indoors , by a window . I switched it to alter hold it waited for any fail msg, none . Then I switched back to gps loiter no issues . It armed no issues . Strange glad I don’t have to recalibrate
ve to calibrate it again I did it when I changed motor it’s sketchy process for me for now . Big bummer is now snow and wind are back for 3 or 4 days .