Servers by jDrones

Skyviper V2450 GPS Unable to Factory Reset


(Jerry Freeman) #1

I was trying to use QGroundControl to fly a mission but every time I tried to upload the mission to the drone, I received and error that stated (MAV_MISSION_INVALID_SEQUENCE. I finally found this on this: (The SkyViper has its own app that runs on android or iOS, but to access the full capabilities of the ArduCopter firmware you may prefer to use another ground station package. The SkyViper can work with a wide range of GCS software, including MissionPlanner, QGC, Tower, MAVProxy etc. For each of them, set them up to listen on UDP port 14550. The SkyViper uses MAVLink2 by default, which doesn’t work with some older GCS software (such as Tower). To use those GCS versions you need to change the parameter SERIAL1_PROTOCOL to 1 from the default of 2. That will allow MAVLink1 GCS implementations to connect. As the SkyViper uses UDP broadcasts you can connect from multiple devices at once.) and changed the parameter.

That still didn’t work, so I decided to do a factory reset from the web page. When the SV restarted it would not respond to the controller. I looked at the web page for flight parameters and there were none listed. I then found instructions for placing facreset.txt on the SD card, but that did not work.

I would appreciate any help getting this reset so I can fly again.


(brad112358) #2

Are you still able to connect to the SV via the app and the web page?

Did you try performing the bind procedure to bind the controller to the SV?

–Brad


(Jerry Freeman) #3

I am able to connect to the SV through the web page. When I open the app it says it needs to connect to the controller, I turn it off and on, but it still doesn’t connect. After I skip connecting to the controller the apps says a firmware updgrade is needed. It seems to updgrade the firmware and says it will need 15 seconds to restart. I let it sit at that screen for several minutes, but it never finishes.

I have tried binding the controller to the SV.

I haven’t tried starting it up without an SD card. I will have to give that a try tonight. I wonder if that will do anything?


(brad112358) #4

I admit I’ve not done this, but it is documented here:
http://ardupilot.org/dev/docs/skyviper.html#transmitter-tricks
Did you follow this procedure?
If so, what was the result? What did you hear? Did you try it more than once? Did you try DSM2 or DSMX?

–Brad


(Jerry Freeman) #5

I tried powering on the drone without a SD card inserted without any luck. I tried powering on the controller, once with the left button held down and once with the right button. The controller seems to make the typical noises at startup.


(Jerry Freeman) #6

Here are some screenshot from the webpage interface.
The firmware page has unknown listed for the transmitter and flight controller and nothing shows up on the flight parameters page.




( .) #7

Thank you so much! This got my wifi broadcasting again…but now my controller starts up and just freezes. i can’t even turn it back off without removing the batteries.


(James Cox) #8

Jerry,

This sounds very similar to my issue here. Curious if you’ve made any headway with your issue? If not hopefully peterbarker can help us out.


(John Freeman) #9

UPDATE: I was able to get it working by using Telnet 192.168.99.1 2017. Using ‘help’ I was able to change the Baudrate to match the firmware that I had inadvertently changed. I then went into the AuduPilot Firmware and reset the parameters. Then I had to Telnet back in and change it to the new Baudrate. There are instructions in a couple of different places but wanted to get the fix for this one so someone else doesn’t have to search to find it.

Thanks to all those that had the information out there. I am not a programmer so it did take some time!

I have this exact same issue. If you got your working, any help would be appreciate.

Thanks!


(Timothy Bessler) #10

I have the same problem, but cannot get the parameters to show up, probably because I have some funky baud rate set in there.