skyviper motherboard/ardupilot brick

So when i wanted to update my skyviper drone i updated it to the firmware that was already on it
Drone powered off but it didn’t power on after it i unplugged the battery. nothing, i unplugged battery and charged it. Still nothing, i unplugged the battery and powered off the controller for 15 minutes then powered the controller up plugged battery into the drone… Still again nothing but i noticed that there is a red/orange light inside of the drone that is just there but it wasn’t before the brick and the drone just acts like its dead no lights instead of the one inside the drone no connection only drones wifi is active so i tried resetting the drone to its factory settings but that didn’t work, i checked ardupilot firmware it says unknown on ardupilot firmware but other firmware’s are flashed i tried flashing arudopilot firmware but that still didn’t work drone is k1617ty and drone’s model is 01736.
Also controller can’t find my drone sensors are not working and system parameters are missing too here is the drone’s photos

It is very difficult to brick a SkyViper. If the WiFi is working just flash the correct firmware again.
Be aware that 2450GPS (2017) and Journey (2018) use different firmwares.
For more information see: SkyRocket Software — Copter documentation

I tried flashing the firmware but it refuses to flash it the drone just stays with the light inside of it and ardupilot firmware still stays as unknown

And this light wasn’t there when the drone worked but after flashing it it justs doesn’t do anything no lamps on the wings controller can’t find it only wifi and the odd orange light inside of it works

Have you tried the recovery options listed in the link I posted?

Do i just put firmwares for flight board transmitter sonix and iq on the sd card or where do i download these folders:

ok i now managed to fix the drone by flashing ardupilot and other github stuff on the sdcard the light inside it dissapeared here are now photos of it



Hey i have a question can you tell me what does the orange light thingy mean because i still have it before drone boots up fully like first its the light and like 3 secs later it dissapears and drone boots up

I don’t know where that light comes from, maybe it’s the Sonix board.

Ive now figured out the light ive been talking about is not the sonix board but its the small lamp hidden on the main motherboard, maybe it flashes like this because its like a warning that the os has been changed maybe, this is how it looks like if its triggered:

Processing: 20220225_004014.mp4…
I can send you a video of it blinking here: 25 lutego 2022 - YouTube