SkyViper Journey mission with QGroundControl

I recently got a Sky Viper Journey, and I am trying to plan a “simple” mission with QGroundControl v 4.1.1 for Android. I define Takeoff, followed by three waypoints in a polygonal pattern, then RTL. The points are spaced by roughly 50 meters from one another. When I execute the mission with my Sky Viper it takes off and flies for about 15 seconds to the first waypoint, then immediately executes RTL. I’ve tried this three times with the same result. I am using the Viper’s factory-installed firmware. How to analyze this problem? I have tools mavlogdump and online UAV Log Viewer. Has anyone successfully defined and executed this kind of mission with QGroundControl and Sky Viper Journey?


1 Like

Maybe - what would I look for specifically in the .bin logfile that would indicate those conditions? Thanks!

The error message that caused RTL.

Dataflash log contains these ERR messages:
2021-05-14 12:36:48.44: ERR {TimeUS : 182616711, Subsys : 2, ECode : 2}
2021-05-14 12:36:48.44: ERR {TimeUS : 182616815, Subsys : 5, ECode : 1}
2021-05-14 12:36:50.25: ERR {TimeUS : 184435037, Subsys : 5, ECode : 0}
2021-05-14 12:36:51.89: ERR {TimeUS : 186072979, Subsys : 2, ECode : 2}

According to this doc, Subsys 2 Ecode 2 means onboard radio received no updates for 2 seconds. Subsys 5 Ecode 1 means radio failsafe triggered - presumably RTL is triggered then? But Subsys 5 Ecode 0 means radio failsafe resolved, and it occurs 2 seconds after the failsafe triggered. Once radio failsafe is triggered, does RTL happen whether radio failsafe is susequently resolved? Then radio reception timed out again - but no subsequent radio failsafe triggered in the log…

Yes. Make a Mode change to cancel it.

1 Like