Skydroid H16 “waiting for video”

Hi! I’m new to this and I have a problem with Skydroid H16 that have lost video stream. There is warning “waiting for video” and black screen. QGC version is 4.1.1

Are you using their default camera on MIPI connector? Or another one with HDMI connector? I have experienced some troubles by connecting other cameras to it, maybe it could be some kind of cam incompatibility… You can try to see if the Video appears in the H16 Tools in order to double check if there is some kind of trouble with your qgroundcontrol installation.

It’s connected on hdmi. Everything was just fine, but during the flight it lost video. H16 tool also doesn’t show video. I have tried binding again, it connects but still no video.

If it’s not showing up in H16 tool and was working before this doesn’t have anything to do with QGC. It’s probably a hardware issue on the drone itself. Assuming your telem / control is still working?

Yes, telem/control is working fine.

But it is also showing this two errors.

Are this errors related to video not showing?

No they are not related, I always get those too even though everything works.

1 Like

Thank you! I’ll check camera connectors.

Yeah, most probably you had some kind of wiring malfunctioning.

Make more one test, add one micro sd in air unit.

Thank you! It was lose hdmi inside vehicle.