Sky viper v2450 gps controller flashes green and red

I am completely lost:(. My drone was working great and now after firmware update my controller just flashes red and geeen between indoor and gps and won’t connect! Please help!

Try following the instructions here to force bind the transmitter.

I am completely new to this so I apologize for what probably seems to be a multitude of stupid questions.

I see a lot of people referring to the status home page? Is that in the app for the sky viper or an internet web page? Also what does TX mean? Again I’m sorry for all the questions?

Also I don’t have a SD card yet I have been letting it store to my phone since that’s what I’m using, should I get a card?

The skyviper has a web app. Connect to the skyviper’s wifi with your phone or computer and go to

It’ll show the web page. Then follow the steps in the link

TX means transmitter. (Controller)
SD card gets better pictures/videos. Also it is necessary for getting the logs off the drone. But you’ll need to get the controller bound first anyways

I tried to force bind the transmitter and it locks on for a second then goes back to flashing back and forth between red and green or gps and indoors???

I’m pretty sure you’re in this code. @tridge can you help @Treysdrone out?

Did you use new batteries? Tx might be too weak?

If you have an SD card, you can set this parameter to log while disarmed, and perhaps it’ll report something…

They were new when I tried them a couple days ago! Also I would love to do what your asking on the sd card but I ha e no idea how?! I am completely new to this which doesnt help my frustration:(

No problem, we all learn together.

If you have a micro-SD card, you can put it into the skyviper in the slot just above the battery holder on the back.

Now that you know how to get into the web interface, connect to the SV, go to the Web interface, then to “Flight Parameters”.
On the drop down, select “All” then search for the paramater "LOG_DISARMED"
Change it to 1 then “leave” the text box (it’ll automatically write)
Now unplug your SV, insert the SD card (if not already) and perform the Tx binding again.

After it unbinds. While still in the web interface, click the big SKY VIPER banner at the top. Then click “Filesystem” -> DATAFLASH -> And find the .bin file. There should only be 1 since you’ve never flown before. If there isn’t, then just get the “last” one.

The file should be small so you probably can upload it straight onto this site. If it is big, then you can put it on a cloud drive (dropbox, google drive, etc) then link to it here.

I won’t let me view it, like I click on it and it says open on documents pro but then says I can’t view the file? And when I try to paste it here it won’t unless I disconnect from the skyviper and connect to my WiFi but then it pasted it like there’s nothing there

Go into DATAFLASH and get the latest .bin from there. You posted the firmware for the wifi board.

To download it you need to right click the file and select save as. Then save it somewhere on your computer (downloads?) . Then come here and click the attach button in the comments field.