Sky-viper SE Pairing issue

I acquired a Journey SE drone, and in trying to test fly it, i cannot seem to get the transmitter to pair with the drone. i have searched extensively and this forum seems to be the only one that mentions the differences between the journey and the se. support from skyrocket is non-existent these days. from what i found on their website you press the left button and hold while powering on, or video and pic button, one said right button…tried powering the drone on upside down to reset as one article suggestion and combined that with various button combinations on the transmitter. now maybe i am way too literal but left button to me is vague and i tried various combination of any button that could be considered left to force a bind. oddly i can connect to the wifi of the drone, and it will transmit a pretty clear picture, but as was stated in another thread the configuration file is not accessible through wifi. sky rocket on their website does not differentiate between the se and the standard journey, but i tried the ip address they suggested as well as the one i sniffed out. ( and i am quite certain i am way over thinking this, but what obvious thing have i missed in trying to pair these? i thought about reflashing but with the differences in the journey se i’m not sure that will work. the only other abnormality i have noticed is on the wifi app it list the fully charged battery as dead. if anyone has some advice i would appreciate it.

The Journey SE model does not use Arducopter firmware but perhaps these guys in this lenghty thread ending with that conclusion can help with your issue:

I did read that thread, but I did not find a solution to my pairing issue. After reading it I was left with the impression that op abandoned the project as he got a non SE version. To add to that thread if we can’t come up with a simple solution to pair the two, I would be willing to autopsy and provide pics of the internals.

Well, if it doesn’t have Arducopter this really isn’t the right forum. I have a Skyviper GPS2450 and I quickly got rid of the controller and use my own radio. But I can understand why you just need an answer to your problem.

Perhaps it’s not the correct forum, however after an extensive search, this was the only forum that Has as much info as it does. So I was hoping for suggestions from folks much smarter and expireinced than I.

Hi John, I’m the OP from the other thread and I just added the comment I’ve been meaning to add for awhile. I haven’t abandoned the project but have purchased used ArduPilot Journeys.

When I was testing out the SE, I had no trouble pairing the provided transmitter. I was under the impression that pairing for a package like this was already done or done automatically on power-up. So, just now, because I have two, I thought I would test that theory. My testing so far shows that the ArduPilot Journey drones and transmitters are not interchangeable out-of-the-box. Each drone connected quickly but only with the transmitter it was shipped with. Which implies there might be a pairing step that has been done already, either by the factory or by the previous owners of the two used units I now have. Maybe it’s in the instructions somewhere but I obviously haven’t needed it so I’m not sure.

I’m going to have a look at the code for both the SkyViper and the transmitter to see what is going on. I’ll report what I find here but, of course, this will only apply for sure to the ArduPilot version. It may be the same/similar on the SE but who knows? But maybe the same procedure will work.

This is why I held out for the ArduPilot version and open source products in general. Problems like yours can often be solved without even having to deal with customer service.

So, right, the radio control protocol used on the ArduPilot Journey is Spektrum DSM2. To get the transmitter to attempt to bind/pair, the left button (Launch/Land) should be held during power-on.

Hard to say what protocol the SE is using but the left button is what is used to initiate DSM2 pairing on the ArduPilot Journey. You said you’ve tried that so it either it’s another procedure or your your unit(s) are faulty or maybe even mis-matched i.e. one is SE, the other is not. Make sure the FCC numbers on both the drone and the TX match. I put pictures of both on the other thread. Keep in mind also that the binding of the transmitter to the drone is not part of the video transmission (or the telemetry (GPS location etc.)?) which on the SE is done through regular 5.8G WiFi.

Not sure what else to suggest. If you have any more questions, I’m just learning but maybe I can help. If you get it solved, please let us know!

Here’s the code from the ArduPilot transmitter. Cypress is the name of the manufacturer of the DSM? chip/module:

    case BUTTON_LEFT:
        printf("DSM2 bind\n");
        eeprom_write(EEPROM_DSMPROT_OFFSET, 1);

If no button is held, no pairing is initiated.

    default: {
        bool use_dsm2 = eeprom_read(EEPROM_DSMPROT_OFFSET);

Just wanted to share that if you insert an SD card with the journey firmware, and update the GPS in the app, it will work!

I don’t know if the firmware fixed it or the GPS update, but I would lean on it being the GPS update. I know this thread is old, but hopefully I can help someone who finds it later.