Sky Viper live video in Tower App

Anyone have any luck getting lvl video from Sky Viper in Tower App? What port does the Sonic Board use to send video?

I have tried messing with Settings- User Interface - Widgets Preferences-Solo Video - Custom Video Stream and put in UDP Port 14550, but I am wondering if that is the right port for video? Edit: Port 14550 is used for Mavlink messages so I suspect that this same port is not used for video stream as well.

The result when you make the change above is a black screen.

Edit: Based on quite a bit of digging, the video widget in Tower is GStreamer which is also used in VLC, so it should be able to pick up the video feed if the right port is given for the custom video stream.

Also, I saw someone mention on a youtube forum that they changed the “refresh frame rate and it works good now for fpv”. Still trying to locate that in the video parameters section.

Anything else that I may be missing to try out?

Thanks ahead of time.

1 Like

It’s on port 554 (I port scanned my drone while trying figure this out for myself, but I am in your boat). I tried setting the Solo video port to 554, but it’s still just black screen. You may already know that, since you found the VLC info, and since it’s a standard port for that purpose (RTSP).

Video is transmitted with the RTSP protocol. Normally the SkyViper video app is used, but you can also view video with other RTSP viewers. The URL is: rtsp:// Viewing video works well with vlc and mplayer

so I’m working a PR to get Tower working with the Skyviper’s Video. I wonder why when you connect to the RTSP port (554) you just get a black window. It doesn’t say “No video” so it recognizes there is something there. Is it a codec issue?
@peterbarker is this one you could help with?

When debugging the Tower App on Android it says the following error when trying to connect to UDP port 554

D/UdpConnection: Opening udp connection.
E/AbstractIpConnection: Unable to open ip connection.
               Permission denied
                            at Method)
D/UdpConnection: Closing udp connection.
D/VideoManager: Video stream disconnected

Any other configs or hints?
It’s frustrating, the “No Video Available” screen.

no sorry, nothing new. i tried working a PR to get Tower’s follow-me mode working again too, but nothing. And I’m not smart enough to break out on my own.

Maybe i’ll think about looking at QGroundControl since it is maintainined a little more frequently i think

1 Like

Solex App is another good alternative. Though it does cost $25.00, I think it is worth every cent.

I have it, but currently I get frequent crashes or freezes when connected to my SV with Solex…not sure why. Think it may be related to using 3.6 RC2 versus the SV stock firmware

Qgc has a nice waypoints interface but just could not Connect to the SV.

Check this out

1 Like

Video stream works in Mission Planner also.

1 Like

Is there any way to record video to SD card while in qgc