Sky Viper Journey Pro Video GPS Drone V2700 -It's HERE!

thanks, but walmart took both the journey and scout back. this was the 9th time i had returned a skyviper product to them since december. guess il try to build one myself unless i can find another lower priced ready to fly brand.

by the way, if anyone needs it i have a lot of flight data and paramater info for the journey, it is definetly NOT compatable with the 2450 firmware. most problems seem to evolve around the transmtter and toy mode. both Qground control and mission planner automatically change parameters randomly.THE STRING FRAME FIX ONE POST I SAW HERE DID WORK GREAT. the gps and compass both failed on a regular basis fron gps glitch and ground mag every 30 seconds and the skyviper app loaded the 2450 firmwae to the scout, then when the journey was ran with it, loaded the scout firmware to it and then the journey would have the flow hold enabled until i cleared it out in the parameters, this applier to both th 2700 and 1849 models.

Hello from Dublin(Ire),
I bought a Sky Viper Journey from a local Toy Store chain.
I was surprised to see that such an advanced machine in a Kid’s Toy shop…after all this is not a simple toy grade machine due to the complex electronic’s involved.
I have been flying around 5 year’s and even i had a few problem’s with it at first…in fact i am still learning thing’s about the machine.
Mine suffer’s from very bad vibration and as a result the footage also suffers from jello affect’s…also when i fly it in Altitude Hold Mode it suffer’s from very bad drift and i still have not figured out how to trim it as there are no button’s to do so on the TX.
When ever i have a rough landing the motor’s take way too long to shut off when it make’s contact with a hard surface.
Any advice on how to solve these problem’s would be deeply appriciated.:+1:

Have you done the preflight calibrations?

Make sure you are well away from any metal even go as far as take your keys and phone off when you set the calibrations.

As for the motors still running just give the power button a tap on the TX for an emergency stop of the motors don’t worry the tx doesn’t power off just by the tap of the button.
This is the active webap interface once you have connected to the drones wifi signal.

1 Like

Hi Matt, I tried your message tab but no luck. I am trying to wire up a 4-1 esc like you did and wonder 1) for the esc, did you route the positive wires from motor plugs to the S1-S-4 and grounds to common (i.e. common to power pos/neg for pcb)? 2)can you use the volt and current pads shown on the diagram to input to those particular inputs on the esc? 3)Do you know what pads on the 2450 pcb would be used for inputs for flow camera or ultrasonic sensor module? I have sussed mounting pcbs to (altered) Ghost frame. 4-1 esc in, backup video camera powered and ready to stack, antennas in, just need to do some soldering! Mahalo Nui Loa! Steve

Hi Steve, see this post how to wire to ESC. You need to connect ground line as well.
Not sure where to connect voltage sense. To detect current, you need external current shunt circuit.

Dave - Since you use the Journey with Mission Planner, maybe you can help me. I’m having trouble figuring out which settings to use in the Mission Planner Wizard for the Sky Viper Journey. Most of the wizard is straight forward, but I’m not sure what to choose to get the battery reading correctly.

Any ideas?

Hi Jim-I actually have a V2450GPS not a Journey but maybe they are the same in this regard. I’m not a big fan of the Wizard, I would just go straight to the Full Parameter list and set these:

Power cycle the vehicle and see if you are now getting Battery Voltage displayed in the HUD. If so then go to the Battery Monitor page of Initial Setup and set the “measured battery voltage” value to whatever your multi meter reads for the connected battery.

Thanks Dave - Good information. I’m not quite there yet, but at least now I know what settings I should be searching for.

Thanks so much, Satoru_Sasaki!, quick question, Matt_M told me you folks played with the Wingsland S6 at the office. Since it uses the STM32F427 processor, are you able to reflash the f/c in that quad with Ardupilot? Thanks!

I do not think ArduCopter is ported to that. This page has currently ported hardware.


Thanks Satoru, I was just wondering if Matt_M had done anything with the S6 unit he had played with. I will work on all the info you are providing. Enjoy! se

Any specs on the motors, gears, and pinions? Googled but cant seem to find. Think I’ll buy one later this year.

1 Like

I just bought the new Journey, and I have experienced some of the same issues. I placed both on a digital food scale and they are very close in weight without the battery (2450 at 116g and 2700 at 117g). Even after calibration I have problems with maintaining position with altitude or gps hold. Descending is very challenging: it behaves like a drone with too much weight. Looks like the gear ratio has changed with 11 tooth pinion and 67 tooth gear, but the props appear to be the same as the 2450. I’ve played with the different modes, but cant really seem to get this machine under control when compared to the 2450. Absolutely cannot fly with any winds more than 10 mph. Flight times seem similar with the 1200 mAh battery. The one improvement I have seen is with the camera. The smartphone app still crashes much like the old app. How I wish they could fix that (I use an LG V30). Much like the 2450, the wifi does still seem to take a while to start up (true for both smartphone and PC). I haven’t yet tried to update, but I hope there are fixes for these issues. Not a great “out of the box” experience especially when compared to the V2450.

I’ve added extra washers in mine to get rid of the extra play on some of the props (not all of them needed it). Balancing the props will help some, but I’ve never been able to completely get rid of the vibrations. I’ve also changed props on the V2450 to 6040 and 11 tooth pinion gear, but haven’t done anything like that on the 2700. Different props was the biggest change in getting rid of the vibrations.

1 Like

Hey Ken, I bought the 2700, and it did a Return To Retailer within :30 minutes of flight time. Back then I didn’t know much (still don’t) but when I recognized the symptoms of a motor fail and then found it soldered to the board, well…
…I hit the “RTR” buttton!
Recent experience in retail suggests that the 2700 was made with the margin in mind, IMO, and it did not compare favorably to the 2450. Mine was 10 grams heavier than the 2450 and totally overwhelmed by thin air here with consistant auto-landings that weren’t.
After trying to use one of the three 2450 pcb sets I have (in addition to a working 2450) and found that it may be defective or beyond my attention span, anyway, I began looking in other directions.
The second & third pcb sets bought salvage appear to be fine on the bench, and will likely get used in a production model brushless frame mod in the future. Once I started buying quality frameS, motor$ and esc’$, for this build tho…
…it began to make sense to look at the Ardupilot compatible flight controllers page.
The plan is to stick with Arduxxxxx for commonality between rotor (Quad&vtol), wing, and even rover (for a crawler) platforms…
…but so much to learn that I haven’t been monitoring this part of the site for a bit. Hope folks keep at it, I will be back for the “brushless upgrade” updates to utizize the SR pcb’s soon. Luck!!!

I think the frame would work nicely for a brushless motor setup. I’m just now looking at flight controllers, gps, telemetry, and video cams. It’s a real challenge to do when I’m trying to keep the weight below 250 grams. Another (and maybe better option) is to use 7.4V micro motors. JJRC did this with their H68G and has a flight time of 20 minutes!! The lightest frame I found on Hobby King for the same wheel size (240) is around 80 grams. Fortunately Arduxxxx is well documented online.

1 Like

Looks like the JJRC H68G has GPS enough to RTL. Will it fly waypoints? Have experienced 20 min flight times? Reviews I see make me wary, but the price point makes it low risk!

Hi. I have the skyrocket journey. Not a professional drone person, hence i bought a cheaper right out the box drone. And i don’t know any lingo. But in the last week or so while using it won’t respond the the throttle and sometimes even drops from the sky. Fortunately never from a high height, often in the 5-10 feet range.

What could be wrong? I tried all the calibrations and even a factory reset and I think upgraded the firmware.

Still does it. Anyhelp would be awesome.


1 Like