SkidBoat: Manual&Acro are working - Loiter,Auto&RTL are not working

I have three planes with ArduPlane running, so I’m a little experienced with that.

Now my first ArduBoat is a skid-boat.
With that boat I have the problem, that the more or less manual modes (Manual&Acro) are running good, but the modes with automatic throttle are not running.
If I switch to one of the automatic-throttle modes (Loiter,Auto&RTL), the boat is turning to the desired direction (skid-turn), but it’s not accelerating forward.
On the OSD I can see the direction and the distance to Homepoint, so GPS is working correctly. And there is no error-message on the OSD.

Maybe it’s one parameter I did not set correctly, but I can’t find it.

I have that behaviour with “ardurover4.0.0_OmnibusNanoV6_26.11.2019stable”
and with “ardurover4.1.0dev_OmnibusNanoV6_20.03.2020latest”.
Here are my parameters:
ArduRover-OMNIBUS-4.0.0-(MODE5=AUTO).param (17.9 KB)

And here a short logfile (see Auto-period: 17:27:14…17:27:26):

Can anybody see what’s my mistake?

There is a problem with that log file. So this is a Omnibus F4 nano V6 Flight Controller? Just checking because it doesn’t show in the log and there are a few Omnibus FC’s.

Motor Right should be on Servo 3 not 2.

All my rovers have their motors connected on servo 1 and 2 (or 1,2,3 and 4). The 1 and 3 thing is something from the past, I thought.

Ah OK, makes sense. I suppose it doesn’t matter, whatever its configured for.

Would you send me a parameter-file from your skid-rover (or skid boat if available) for comparison, please.

Sure, no problem:

Arduboat40.param (15.9 KB)

I wonder with WP_SPEED at 0 and doing a cruise speed learning during the same power cycle did not cause a problem with the speed in AUTO. Looking at the logs, the speed vs des speed, the boats doing what it think it should.

Thank you, I’ll try that as soon as possible.

For some reason your parameters were not available from the log. The ones I looked at were from the param file you posted. Nothing jumped out at me from the param file. I’ll boot up my boat and send my params in a little while.

Oh, I missunderstood. Now I remember that WP_SPEED=0 is a valid option - to use CRUISE_SPEED.
But I will try to change RTL_ ,WP_ and CRUISE_SPEED to 1.6 e.g.

Here are my params. It’s currently set up for ackerman steering. It works fine with skid steering and depending on mission I switch back and forth when needed.

2020 April 12th params.param (16.3 KB)

Thank you all,
It’s fixed. After the hint of David I tried it in SITL.
The Cruise-Speed-Learning is just learning the CRUISE_SPEED.
If WP_SPEED=0 then there is no movement in AUTO or GUIDED.
If also RTL_SPEED=0 there happens additional no move in RTL.

1 Like

In previous versions it would default to CRUISE_SPEED if no WP_SPEED was entered. It may be different now but I’m not sure. I can’t even remember at the moment what code I am using. LOL. :rofl: