Servers by jDrones

Skid sterring boat direction error

(Pierre Gogendeau) #1

Hi all,

In a conservation project for developing new tag for marine turtles, we need to do oversea channel radio characterization of LoRa signals. We were a bit tired to do it by boat so we decide to build an autonomous boat. We also plan to help reef conservation and habitat mapping adding an echlogger coupled with a camera for shallow water.
I’m trying to build a skid strering boat using the pixhawk cube. The boat is made with a old surf board with 2 blue robotics T200 thrusters. I’m using ArduRover V3.4.2 firmware with Mission planner 1.3.62. The boat functions like I want in manual mode but I have errors in direction in Automode. The direction error can be more than 90°. I tried to set up my parameters following the ardupilot Rover tutorial and then some setup that I saw in this forum. (For instance setup of David_Boulanger).
I did my test in a harbor(Le Port, Réunion island). I tried first some really simple mission. Just one waypoint in front of the boat. When I switched to Automode the boat go in the wrong direction all the time and doesn’t seem to correct the direction. On my laptop screen when the boat doesn’t move the heading seem in the right direction. I will be happy with any kind of advice for the setup.
You can find attached link to the log file (https://transfernow.net/23c6r651wdb6) and the param file USV_22-07-19.param (11.8 KB) . I often stop the Automode to avoid collision with wall and other boat. I’m a bit lost to try to read and interpret the log file. If you have some advice of which param are important to check first, etc… Maybe for my case I need to check the yaw ? To be more clear maybe I can also make a video of my screen the next time.
Cheers
Pierre Gogendeau

(David Boulanger) #2

Before I look at the parameter file does it hold a good course in steering mode?

(Pierre Gogendeau) #3

Hi,

I did a new test today. I tried to tune again my parameter like it is explain in the tutorial but I face some problems. I tried strerring mode and acro mode. In sterring mode the boat turn in circle (inverse of clockwise). You can see it in the image bellow. When I touch the stick It goes totally wrong (circles in other direction or wrong directions)


I display the PID desired and PID achevied and it’s seem I have a offset of 20deg/sec when I don’t touch anything. That corespond to the circle that the boat made.
In manual mode I made some circles too with only RC1 or RC3 and I have a PID around 30 deg/sec.

I tried again AUTO mode. The boat make a little turn around. Find a direction and go straight to this direction that is totally false. I tried to start the mission to several different locations. And the result was the same. One time in AUTO mode the boat seem to follow the good direction but struggle to keep it and made a lot a small circles and turns.

I’ve have seen that I had a parameter very low : Sterring mode turn radius to 0.1, maybe It’s a part of the problem ?

Do you know a solution to stop and start a new log file ?
Here are my log file https://transfernow.net/66ei62719vcl and param USV_23-07-19.param (11.8 KB)

EDIT : I had a doubt and shame on me I mounted the thrusters in the wrong sens. I will try again tomorrow…

(David Boulanger) #4

If the thrusters are spinning in the wrong direction you may need to change the wires from the ESC or look into reversing SERVO_1 and 3.

1 Like
(Pierre Gogendeau) #5

Ok, I will reverse it or change the mounting on the board. What do you suggest for a starting value of Turn radius ?
For the next test do you know a method to sample different log files ?

(David Boulanger) #6

I tuned my boat not using differential steering. My turn radius is set to the radius of a smooth turn at a speed of 1.25 M/S. I think it is 2 or 3 in my case.

(David Boulanger) #7

Get it working properly in steering mode before trying any thing in Auto

(Pierre Gogendeau) #8

Hi David. Sorry for this late answer. It was impossible for me to go to the water and now i’m in holidays. As soon as I come back I will do the tests again. Thanks

(David Boulanger) #9

Randy has a nice tuning guide in the Wiki using ACRO mode. I choose to do mine using STEERING and AUTO and then reviewing logs.

(Pierre Gogendeau) #10

Hi David. I was away for a long time but I strat working again on my USV. You were right about the wiring of the ESC. One of my thruster was in the wrong way. I change the wiring of one of the thruster and now the USV is working well. I will start the fine tuning of the streering and auto mode in the following days. Thanks !

1 Like
(Pierre Gogendeau) #11

Hi David and all,

I did some test today. I tried Accro mode and Auto mode.

In Auto mode I made a square of 4 WP. In the straight line it was ok without oscillation. For the short 90° turn the USV oscillates 2 times and overtake a bit the WP. I don’t understand why the USV doesn’t braek , then enter in the pivot turn mode slowly, make his turn and then accelerates again. The USV accelerates during the 90° turn. I tried to decrease first PIVOT_TURN_RATE to 45. The path was almost the same. Then I reduce the WP_RADIUS to 0.5, and a didn’t see real improvements.

In accro mode I tried to set up the steering rate. Compare of what I read in another post a get some weird values : P = 0.45, I = 0, D = 0, FF = 0.6. In the graph comparing the PID desired and the real PID I always have a delay for the real PID and I don’t know how to get rid of it. I tried several combinations for instance same P and D at 20% of FF (I read that in other post) but the result was worst.

You can find my log file attached : LOG_FILE I think it is a bit messy because a tried several things. I will try to take some screenshots and separate the log file for the next time. (Any clue how doing that ?)

Any help is welcome to tune my USV :slight_smile:

(David Boulanger) #12

you will probably find with a boat the FF needs to be around 2 and the P and I around .5. Your bread crumb trail actually looks good for a boat.