Skid steering with obstacle avoidance, rover goes in circles

I have ardurover latest beta release installed and a sonar. I use skid steering and have rc3 trim at 1500. When the sonar sees a obstacle it begin to go in circles.

I use brushed motors with two esc (left and right side). I think I use rc 1 and 3 to the escs.

I don’t think I have doing any reverse for the rc channels. Parameter Avoid type to stop.

I also tried to lower the rc trim to 1000 but it does not solve the problem.

Any suggestions?

Hi Micael,

The vehicle drives OK in other modes like Acro and Auto?

I guess you’ve seen the object avoidance wiki page of course? Maybe RNGFND_TURN_TIME is too long? It’s just a guess… if you have a log I can have a closer look.

Hi and thanks for the information.

I begun to build a Y6 copter and took the pixracer from my rover and later I will use a revolution F4 FC instead when rover firmware becomes final version. I tried to delete thiw thread (topic) but I don’t know how to do it.