Skid Steering boat not going strait at low speed manual mode

Hi builded a boogie Board. It work great in auto mode and follow lines without overshooting but in manual mode it is not fully working.
At full throttle the board go straigth but when going slowly the board is turning rigth all the time and I have to compensate to make it go strait. I feel the sensitivity of the left motor is higher than the rigth motor. When slowy increasing the throttle, the motor kick in faster and the board turn rigth. At full power they match and the board start to go strait.
I tried to make them kick in at the same time by changing the trim value. I used 1500 usec on one side and 1495 on the other. With this tweeking, both motor do kick in simultaneously, visually on my bench, but this difference don’t seem to be enoug to correct my problem. For any slow and intermediary throttle value I have the same problem. For example, I tried to limit the throttle to 30 % and the board just turn in circle! Is there a parameter somewhere for this?

I have Tlog and bin file to look at.
I am using Pixhawk 2.4.8. Left is on servo1 and right on servo2.
I run the latest ardurover/boat


Sounds like euc pwm cal stuff not a problem with the flight controller put a y lead on the euc and see if the motora appear to be going the same speed through the ranges.

1 Like

Hi @Mirmi,

I think your idea to change SERVOx_TRIM values is a good one. I think also modifying the SERVOx_MAX values may help. Each ESC is separately converting the PWM input that it’s getting into an output current which it then sends to the motor. It’s possible for different ESCs to come up with different results because of clock speed or (more likely) because of calibration differences. If you can either re-calibrate the ESCs or modify AP’s SERVOx_MIN/MAX/TRIM values so that they match each ESC then the problem could go away.

The other possibility is that it is the motor that is not producing the same thrust for a given current. E.g. the motor outputs don’t match. You could test this by swapping the motors (but not swapping the ESCs) and see if the boat turns in the other direction or not. If it turns in the other direction then you know it’s a motor problem. If it turns in the same direction then you know it’s an ESC problem.

1 Like

Randy if we use dshot for esc control does that mean esc calibration is effectively bypassed? By that i mean the esc is just set 1000 - 1500 - 2000 and no fine cal settings ie 998, 1504 erc are needed as trim settings like they are for pwm

I have some f35 escs on dshot and i have had heaps of troulble where i cant get them to produce full power without setting back to pwm for esc cal then returning to dshot… but in my mind dshot should alleviate any need for esc cal as the value is digital from fc to esc ?

Hi @Scott_Nunan,

I would have thought that if dshot is used then there should be no need to calibrate the ESCs. What you describe though sounds like those particular ESCs do need to be calibrated, or perhaps it is just a bug that they are affected by the PWM mode calibration. This would all be inside the ESC firmware though so I’m just guessing.

BTW, when using dshot, I think the AP PWM output range should be 1000 ~ 2000 so AP’s servo output params should be set like this:

  • SERVOx_MIN = 1000
  • SERVOx_MAX = 2000
  • SERVOx_TRIM = 1500

Hi @rmackay9 and @Scott_Nunan , thank you for the replies. I did a couple more test and playing with the Max PWM seems to help by boosting the rigth motor. In my actual configuration it is not easy to swap the motors. I will have to think about this a bit more.
I will try re-calibrating the esc.
It do not matter that I use servo 1 and 2 instead of servo1 and 3 right?


Hi @Mirmi,

Just to answer your last question, it doesn’t matter if servo1 and 2 or 1 and 3 are used.