Skid Steer Servo Test Not Working

Hi All,
I’m using ardurover 3.5, pixhawk and a [cytron motor driver.] on a diy rover setup.
(https://forum.cytron.io/viewtopic.php?f=4&t=13090&sid=ea95d744c5cc8ddefd72e496aac778e2)
I’ve done the initial setup & calibration and scanned the forum and tried to debug, but I’m still learning and I can’t get my motors to work in the “Motor Test” area of mission planner (v 1.3.62). Image of my setup and settings file attached. I’m super stuck!! Does anyone see anything wrong in my settings file ?
Many thanks, David

ardupilotparam.param.txt (13.0 KB)

I had a quick look at the parameters and didn’t see an issue.

We can probably figure out if it’s a flight controller issue or ESC issue by checking what the flight controller thinks it’s outputting. The easiest way to do that is to check on the MP’s status screen and look for ch1out and ch3out. These are the pwm outputs that the flight controller thinks it’s outputting. If these remain at zero or don’t move during the servo test then we have an issue in the flight controller’s setup. If the outputs do move but the ESCs/motors don’t respond then it’s likely an issue with the ESCs/motors. A servo tester like those sold by HiTec are also useful to help figure out where the issue lies.

Thanks for the response!!
After connection those status show 1500 before arming. after arming the numbers are a few ± of 1500 and using the rc controller they change.
When i perform the test i get a single beep, then if i go back to the flight data page it shows disarmed. I also noticed a “Bad Logging” message on the flight data page that I hadn’t before. Could that be stopping the motors from working?

Going back to your response. To make sure I understand - Since I’m getting a change in those status the problem is somewhere between my pixhawk and ESC - possibly in my connection?

Many thanks for your help!!

OK, so it may be that the vehicle can’t be armed and this is preventing the test from working. Setting ARMING_CHECK so that Logging is not checked (it’s described in the wiki’s Log section how to enable/disable individual checks) will likely resolve it but it’s good to have logging working otherwise determining the cause of a future failure becomes difficult. Perhaps try a different SD card.

Thanks, ARMING_CHECK already had no checks. It’s set to 0.
So I guess I’ll focus on the motor driver? - perhaps try to get that working standalone with RC.

@dhumpherys,

Yes, removing the flight controller from the loop and trying with a stand-alone receiver or servo tester would be a good test I think…