Servers by jDrones

Skid steer rover not executing mission in auto flightmode

(Diego Rivas Lazala) #1

Hello, everyone!..Once again. I need help with my skid steer rover because the mission planner shows that the vehicles can go into auto mode but the rover doesn’t move while the mission is being “executed” as stated in the messages tab of the flight data. The only movement I can receive other than perfectly being able to drive the rover in manual is if I hit RTL on the flight data screen, but if RTL is in the mission the rover doesn’t move at all. One issue is that when I do hit RTL the rover just goes in a circle nonstop. I’m running a 6 wheeled skid steer rover with a sabertooth 2x12 (dip switches set to upside up [DUUDUD]) and on ardurover 3.5. Looking for any advice! Please!
Here are my parameters and data flashlogs from earlier today when: https://bergenorg-my.sharepoint.com/:f:/g/personal/dieriv21_bergen_org/EgEUe6Db_NNBvPf4Eb1QGAcBalY1w19061I__u_ZlWZVkA?e=caYXAY

(rmackay9) #2

Arming checks have been turned off it seems (ARMING_CHECK = 0). it is normally better to resolve the issue rather than to just disable the check. We added those checks for a reason!

I think the issue is that the EKF hasn’t gotten a good position estimate. The number of satellites is a bit low at only 11 maximum. Most modern GPSs will get 18+ especially in North America. Not sure why it’s so low on this vehicle.

Looks like the vehicle is back on 3.4.2 so it might be good to upgrade to 3.5.1 although I don’t think it will resolve the problem we have added some EKF checks which will probably mean the vehicle will fail to enter the autonomous mode instead of entering the mode but then fail to move.

(Diego Rivas Lazala) #3

Thank you for the reply. I had turned on all of the arming checks and had gone through the process of eliminating other errors I was receiving on my messages tab like the difference in trim minimum and maximum along with compass inconsistency (which I had solved through turning off the internal compass of the pixhawk). Now, I’m getting a message of bad compass health and still the EKF messages of velocity_horiz and pos_horiz_abs as off. How can I turn off these parameters corresponding for these functions on the pixhawk? But will turning off these sensors allow my vehicle to work in the auto flight mode?

(rmackay9) #4

I think the issue is mostly the GPS. Which GPS/compass module are you using and how is it mounted? also you’re doing the testing outside of course? GPS won’t work well indoors of course…

The bad compass health could be a major problem although i see two working compasses in the logs so I’m not sure why that message would be appearing.

the heading of the two compasses (one internal, one external) are very different though (off by 60degrees) so it might be a good idea to disable the internal one (COMPASS_USE2 = 0).

(Diego Rivas Lazala) #5

I apologize for the extremely late response but I’m running the default secondary compass that comes with the pixhawk, which has the 3DR logo on top of the module.
It’s mounted as such on my rover: https://bergenorg-my.sharepoint.com/:f:/g/personal/dieriv21_bergen_org/EuhlK6zIiaNEnNk0f-54OZIBede_Baae5RMw4H_bkjKVVg?e=aW7m0o

(rmackay9) #6

@Diego_Rivas-Lazala, It might be good to leave it outside with a clear view of the sky for a really long time before trying to start the mission. Perhaps leave it for 15min disarmed and see if that makes any difference. The next step may be to purchase a newer GPS.

(curt carroll) #7

11 SV count could be an old GPS only or RF interference from the telemetry.

1 Like