Servers by jDrones

Skid Steer Rover moves backward in GUIDED mode. - FCU Crash: Going to hold

Hi all,

I am using a Skid Steer Rover with Pixhawk 2 cube.
Pixhawk 2 cube is flashed with Rover-3.4.2 firmware. Jetson TX2 is used as a companion computer.
Recently, I am facing some issues in the GUIDED mode.
Here is what we have done,

  1. Removed GPS using GPS_TYPE=0, and I used wheel odometry alone alone for indoor pose estimation.
  2. I did set “origin” and “home” through mavproxy map.
  3. Then, I used mavros to test the GUIDED mode. Suddenly, all the motors started to spin backwards. The mavros GCS mesages said that “FCU: Crash: going to hold”.
    The motors didnt stop spinning even after setting the HOLD mode.
    Then I tried to set “rc 1 1500” and “rc 3 1500” in MANUAL mode. The motors backward spin didn’t stop.
    Then I increased “rc 3” in steps and observed that motors stopped spinning when “rc 3 1850”
    Looks like trim value was set to 1850 automatically after FCU crash instead of rc 3 1500.

This issue didnt happen all the time.
It happens once in ten times.
So, I am sure that my SERVO and TRIM params are correct.

Please help me to sort out this issue. I am also attaching the log(https://drive.google.com/file/d/1dBO57IrXxa97gjne5wO9rczyLGKu3YsE/view?usp=sharing) which I captured when “FCU: crash going to hold” occurs and after rebooting through mavproxy the motors continues to rotate as shown in the following log( https://drive.google.com/file/d/1fhINkHendxqQtnY6JACUkBwow-mNOu4o/view?usp=sharing )

Update 1:
Another points to be noted is
The graph of THR.DesSpeed is different from THR.Speed
THR.DesSpeed

THR.Speed

And here is the graph of THR.ThrOut
Looks like I have given 70% throttle (rc 3 1850) to stop the vehicle running backwards.

@rmackay9, Hi, Is this problem (Problems with movements) solved?
I am also using Roboclaw motor driver.

All the four motors continues to spin backwards even when THR.Throut is zero.

Hi all,
This issue is due to minor misunderstanding.
The Roboclaw motor driver has some autocalibration functionality during the initial stage for 2-3 seconds. We are expected to give TRIM value PWM for initial 2-3 seconds.
So, This issue is not related to Ardupilot.
So, this can be closed.

1 Like

Hi @AjithKumar,

Sorry for the slow response, a lot of my time recently has been taken up by the Copter-3.6 release.

Glad you got it sorted out.

I’ve also seen this bad behaviour with the Robotclaw motor drivers. I wonder if there is a way to turn-off this auto calibration. I suspect there is…

The “Crash: going to hold” message is from the crash check. This can happen when the vehicle is in an autonomous mode and it finds that it’s not making progress towards the target.

1 Like

Please download and read the RoboClaw manual. Page 50 deals with RC Control and details how to turn off start up calibration (enable MCU mode.) When start up calibration is disabled, Text and chart on the page give conflicting information on the values for full reverse and full forward.

Stopped should be 1520uS.

Full reverse is either 1120uS (table) or 1250uS (text)
Full Froward is either 1920uS (table) or 1750uS (text)

1 Like
Servers by jDrones