Skid Steer Question

So I have a large canoe with a Laptop and a autopilot program I wrote
in VB6. This boat has done hundreds of km of surveys and published a paper on its operation.

This was years ago but now I want to upgrade to APM… So much simpler as I fly copters all the time.

But there is a problem with my setup…

APM 2.0 with one big Speed Controller with full forward and reverse for 2 motors…

I set bot the parameters in the list to Skid steer and in manual mode, the boat drive perfect.

But when I put it in auto it takes off full speed reverse… This is because it seems

skid steer is setup for 1100 ms stop… 1900 ms full forward…

My speed controller uses 1100 full reverse… 1500 stop… 1900 full forward…

See the problem… Thanks for your help

Eddie Weeks

What version of the ArduRover2 firmware are you using? The skid steering in Version 2.46 does not function correctly. Please use either v2.45 or v 2.47 beta 1
For the skid steering your should have these skid steering parameters set to:
I assume that you are using the elevator joystick for speed control and the aileron joystick for steering control.
The skid steering will use whatever channel you have designated as the speed control.
You cannot use the throttle joystick with an ESC that has neutral at 1500us.

I have built a twin pontoon Remote Survey Vehicle (RSV) that uses skid steering and I have added a Garmin Intelliducer Depth Finder and Adafruit GPS/Data Logger to do depth surveys of inland lakes, channels, and ponds:
It uses a 3DR APM2.6 and GPS/Compass module for autonomous navigation.

Yes I had Version 2.46… things were not working well at all…
Installed the beta version and its acting completely different now on the trailer…
Once its in the water tomorrow I am sure it will be fine…
Thanks for your help… I never would have figured this one out…
I will install an APM 2.6 and good GPS and compass soon.

Eddie Weeks

Ok the boat with skid steer runs fine… In Manual every thing works perfectly…

And in Auto it run missions, and is completely reliable.

But… Its not good enough for what I want…
My plan is to put a side scan sonar on this boat is scan the whole of LSU lake.

Because the side scan shoots beams out each side, the heading Must be maintained very accurately
and any changes must be small and slow…

I ran the boat for 4 hours changing parameters slowly each time… And as soon as I get it to stop weaving it does not stay on course. The boat has a lot of inertia and it just overshoots the correct heading…

I built a boat a while back with one trolling motor and a steering servo… That worked perfectly from the start… I may have to push this boat with one motor…

I suggest that you replace the APM2.0 with a Pixhawk in order to be able to use two GPSs and enable the Extended Kalmn Filter (KLM) function for improved navigation.
I believe that the APM2.0 is totally outdated for your navigation requirements.


Just joined the forum and I have similar problems although this topic is old

My boat has two thrusters on a small 1m long boggie/surf board and it turns on the spot. In manual mode I can get it to run just fine and only input little amounts of steering to get it to steer slowly but when I put it into autonomous mode it seems to work but is very “snappy” and seems to apply full thrust to one engine instead of just a little bit at a time.

Also I have set my waypoint radius up to 10m but when the mission file gets sent over and I then pull it back it reads 0m. This seems to have the effect that it never seems to get past the first waypoint. The waypoint radius command is set to 10m as well.

I’m using APM 2.6 and APM2planner

Any ideas would be appreciated and im hoping to upgrade to pixhawk soon.

The WPNAV_RADIUS is set by that Parameter in the parameter list. Its not per WP.

I believe that the APM2.0 is totally outdated for your navigation requirements.
How so is it outdated for navigation? It has full mission support. It doesn’t have auto generated wp functionality.

Hi Bill

Thanks for the reply, thought the topic might have gone dead. Best to scrap apm2.0 and just use mission planner instead then? I currently have

1.3.38 build 1.1.5983.12141

Any ideas on how I can cure the snappy skid steer where to much throttle seems to go to the engines?


APM Planner 2.0 is NOT totally outdated. You can use it. (that was just @TCIII opinion) As the maintainer of APM Planner 2.0 I’m biased, but it also the truth. The issue mainly are around APM Planner 2.0 does not have mission auto generation features for mapping.

downloads are here