Servers by jDrones

Skid problems V2

skid-steering
(Eduard cabanas Gili) #1

Hi all again,

Today I tried to put my skid rover into auto mode and it has been a disaster again.

First of all: in manual mode forward and backward goes perfect, but when it turns left turns ok, but when It turn right the rover makes a reverse throttle…very strange, better see the videos.

Later I just tried the auto mode, a straight line to waypoint 1, pointing to the north and the rover went to the east without any sense

I attached some videos and the logs
Turn problems: https://www.dropbox.com/s/eg7fgezefucksba/turn%20problem.MOV?dl=0
Auto problem: https://www.dropbox.com/s/eb46p9ojrlj4wi2/Auto%20mode%20error.MOV?dl=0
LOG: https://www.dropbox.com/s/sqxwovwo2ycc1uq/00000001.BIN?dl=0
Thank’s for your patience with me.

Best

Eduard

PS: if you come to Barcelona you have invited a paella :wink:

(rmackay9) #2

@ecabanas,

I think the issue with the vehicle’s left wheels not turning properly is because of the SERVO1_TRIM or SERVO3_TRIM do not match the ESC’s dead zones. I think it would be good to use the motor test screen in the MP to test that the speed of the two wheels is roughly the same for a provided throttle percentage. I think you’ll find they are not the same. This can be adjusted somewhat by changing the TRIM values. It would be easier if this MP enhancement was made but that may take some time.

It may also be a good idea to re-do the RC input calibration after ensuring that the transmitter tabs are in the middle. The RC3_TRIM is suspiciously low at only 1437.

The log only seems to show manual mode so I’m not sure what’s happening in auto mode…

It looks like the arming checks have been turned off. Is there any reason for that? Normally it’s best to address the problems rather than to disable the checks.

(Eduard cabanas Gili) #3

Hi @rmackay9

Still with problems but I think I know where is the issue, but i don’t know how to fix it.

If I move the throttle stick up or down the wheels goes ok, If I move right or left goes ok too. But when I want to throttling and turn did not work.

When I speed up and turn right the channels are ok, but when I want to turn left, the ch1 reverses.

I re-setup radio, and calibration as you mentioned before.

Video example: https://www.dropbox.com/s/740qno0u1zh3v4y/reversed%20ch1.MOV?dl=0

Thank’s

(rmackay9) #4

From the video it appears that when the steering stick is moved to the right, the vehicle will actually turn to the left. The throttle also appears to be backwards (as you’ve noticed in the video) so I wonder if perhaps the SERVO1_REVERSED and SERVO3_REVERSED should be changed. Or possibly it’s the input that is reversed in which case the transmitter’s configuration can be changed (i.e. change it in the transmitter instead of changing it in the ardupilot parameters). The MP’s Motor Test page can also be used to ensure the wheels are moving in the correct direction.

Also please note that when the vehicle reverses, by default the vehicle will act like a regular car even if it’s a skid-steering vehicle. I.e. if the throttle is reversed and the steering is left, the vehicle with rotate clockwise. There’s some discussion about this here on the wiki.

(Eduard cabanas Gili) #5

Hi @rmackay9

Problem Solved!!! the issue was the Pilot_Sterr_Type, setting this parameter to 3 the issue has been fixed.

Thank youuuuuuuu

1 Like