Servers by jDrones

SITL - validate_structures:474 - Windows + cygwin64 - mavproxy - XPlane 11

Hey everyone, thanks for having this space.
I will try to be as much clear as I can.

I am trying to connect SITL with XPlane 11.
Everything I tried was mainly based on this 2 docs:

Since I tried most of the configurations or ways to make this SITL as I understand so far, that is, using Mission Planner as GCS with last build, and selecting XPlane for the sim, or running sim_vehicle.py as described on the docs, I end up trying the last one which I believe will help me to understand what is not working.

I am currently trying to success on this SITL doing the following, will adjunt some images to complement:

  • I have installed cygwin and cloned arduplane on the usr folder, under windows.
  • manually build from latest code from master. Version “ArduPlane V4.1.0dev” from version.h file.
  • run SITL from the build and connecting it to xplane with the command: ‘build/sitl/bin/arduplane --model xplane’
  • Have the PT60 plane model running on xplane before previous command is launched, and setting up the UDP ports as defined on the default result from previous command: ‘send from xplane on UDP port 49001, receive on xplane on UDP port 49000’
  • After I have xplane waiting, and after running manually the SITL command, I start mavproxy with the following comand: ‘mavproxy --master tcp:127.0.0.1:5760’

Everything on the same computer.

I got the error defined on the title of this topic “validate_structures:474”, in which the simulation stops, and got the link down on mavproxy console.

You can see everything summarized on the following image:

I don’t know what validate_structuture neither what 474 error is meaning.

I’ve read this topic (Arduplane sitl output stops at validate_structures:401 when I connect with Mavproxy) and since it seemed that the issue was that the build wasn’t being succesfull I tried to check that, but it seems I am having a succesfully build.
I have some weird messages though which I don’t know if they are related with this validate structures or not, have this images as illustration:

I’ve tryied many things at this point, I don’t totally understand this validate structures, so I was trying to think if somehow the model, wherever it comes from ( xplane or SITL? ) may not be well defined.

So I read from here https://ardupilot.org/dev/docs/using-sitl-for-ardupilot-testing.html#using-sitl-for-ardupilot-testing that the first time mavproxy need to have the params loaded.

So, tried to load many .parm files (plane.parm on ardupilot/Tools/autotest/default_params, one arduplate_default-params that I got from ‘param download’ command, and one PT60.parm file I found somewhere). The command load doesn’t work, neither does it the forceload. If I hit param check, I got unknown vehicle type.

I will add some pictures so you can undestand what I am trying ( in this case I am only trying to load the .parm file ):

param not recognized 1

Other things I tried:

  • Mission Planner SITL and MavProxy ( NO XPlane ) -> works fine, takes last build from master
  • Mission Planner SITL selecting XPlane tag -> got connection time-out.
  • I think I also tryied selecting a plane different from the PT60 on xplane, since I don’t remember where I got the model from, so I used one that came with XPlane, but nothing changed.

Let me know any thing you might need to understand what is happening, or if there is anything I can do to get more information. (It would be great to understand what the validate_structures:474 means, or if there is anything related to the plane model either on xplane or on the SITL through the .parm that I am missing or misunderstanding.)

Thanks, I really appreciate this space and all the support around this great community!

I’m pretty sure your problems aren’t stemming from the validate-structures stuff - it just happens to be the last thing in the output there.

Try dropping another Debug line at the bottom of https://github.com/ardupilot/ardupilot/blob/master/libraries/AP_Logger/AP_Logger.cpp#L523 to verify

I’m afraid I don’t have a great experience with either of XPlane or cygwin.

It’s entirely possible that our XPlane integration has been broken somehow…

Tested again now, I usually use it to test with SOAR, no problems.

Servers by jDrones