SITL vagrant up failure

Hi, everyone. I’m following Setting up SITL using Vagrant But I have a problem when I do vagrant up as shown in a uploaded picture
and I am stuck in this for a day. What can I do to fix this problem? I’m using git-bash terminal and do all steps as described in wiki.
Thank you.!

That looks like a transient network issue - not able to reach a server.

One thing you can do if this is happening a lot is to run a local proxy for the packages - it may make things more reliable.

I use:


(and run squid on that port)

Thank you for answering peter.
But could you explain more about it?
I typed as you said into git-bash terminal and did again but same problem has occurred.
I am new in linux,git and all kind of things so I’ve searched about it but I still don’t find appropriate answer. In google, they all use ubuntu and use sudo apt-get to install squid which can’t use in git-bash. I saw there is a way to use sudo and apt-get in git-bash but I think it is not a proper method to solve the problem.

I am wondering that is it possible to run a local proxy with git or do I have to use another terminal like cygwin or ubuntu? Is there a article from which I can get some information?
Could you explain to me for more details? I really appreciate for your help.

How many times have you tried bringing this machine up?

This looks like it should have been a transient error.

Suggest doing vagrant destroy -f and try bring it up again from scratch and seeing if that works.

I think I am doing this almost 10 times. I reinstalled vagrant and virtualbox and do vagrant destroy -f and now this happens!error2

This is really looking like significant networking issues.

Try repeatedly running vagrant provision - at least that way you may eventually get everything downloaded!

It seems like it works for first few times but it eventually ends in here
and remains same.
Maybe is it time to find other ways which aren’t using vagrant?
I really appreciate your help. Thank you.

That’s real progress.

And that’s a real bug in our build-a-Vagrant-instance script.

Well, it was. I’ve just pushed a fix up.

Can you update and try again, please?

In fact, you can probably continue with the vagrant instructions from where you’re up to - it’s basically finished the setup, and you can just vagrant ssh in etc etc.

Thanks to you, I could finally finish vagrant up!
So I tried to start running SITL with vagrant ssh -c “ -j 2 -v ArduCopter”
and result is

It seems like it’s almost done.
What can I do to solve this problem?

Please try:

vagrant ssh -c “ -j 2 -v ArduCopter” -- -X

I’m assuming your host operating system is Linux here. Some DISPLAY environment variable seems to exist in the environment on the guest box - but it is invalid… The -X here explicitly says to make your local display available to the guest machine.


My host os is Windows 10 and I am using Git bash terminal. Do I have to install additional programs?
Does vagrant shell in Docs mean another shell not git bash? But when I start a vagrant.exe file, nothing happens.

OK, try “-x” instead of “-X” to disable ssh forwarding. I’ve no idea how that DISPLAY environment variable is being set - I don’t use vagrant under windows here.

I don’t know reason but it failed again to download some files during a progress of vagrant up.
I think(and wish) it would be a temporary problem. I’ll try it again a few days later.
Thank you for your help, Peter.