SITL Tailsitter fails to hover

I am trying to simulate Tailsitter (Quad-X) using built-in simulation in MP in Windows.
I have also FlightGear to visualize. I have started with normal Airplane simulation model.

Parameters I changed to make it Q
Q_TAILSIT_MOTMX=240 (motors 5-8 populates itself when above parameters set)

Everything appears to be working except Q modes. Transition from FBWA to QSTAB begins, plane starts to pitch up a when it reaches 90deg in FlightGear (or 0deg at MP) plane starts to violently pitch down. Sometimes it overshoots 90g and do loop instead.

Adrupilot send me this message: Transition VTOL done, timeout

It looks to me like simulated aircraft is not powerful enough to keep hovering. But when I try to climb straight up in Acro mode, there is enough power.

I have also tried to make simulated plane act as acrobatic plane with only one motor and it also fails (Q_FRAME_CLASS=10, Q_TAILSIT_MOTMX=0)

Then I run simulation wit Quadplane simulation model and effect is similar, but different. Vehicle pitches us and then starts to oscillate in all axes like crazy. I have tried to tune PID but no effect.

Only simulated Tailsitters I have found on the Internet and youtube are simulated in RealFlight which is expensive and I do not own it.

Also, I have not found a way to begin in QSTAB mode with virtual aircraft vertical.

What is latest and preferred way to simulate tailsitters?