SITL Simulator Compile Error

I’m trying to compile ArduPlane for SITL simulation. I cloned the Github repo, used the Arch Linux install script to install packages for me (I use Arch, btw), and then ran ./waf configure --board sitl, and then in ArduPlane/, I ran --osd --console --map, and I ran into this error:

[476/902] Compiling libraries/AP_Terrain/TerrainIO.cpp
[477/902] Compiling libraries/AP_Torqeedo/AP_Torqeedo.cpp
../../libraries/AP_Soaring/AP_Soaring.cpp: In constructor ‘SoaringController::SoaringController(AP_TECS&, const AP_Vehicle::FixedWing&)’:
../../libraries/AP_Soaring/AP_Soaring.cpp:171:17: error: member ‘SoaringController::_polarParams’ is used uninitialized [-Werror=uninitialized]
  171 |     _speedToFly(_polarParams),
      |                 ^~~~~~~~~~~~
compilation terminated due to -Wfatal-errors.
cc1plus: some warnings being treated as errors

Waf: Leaving directory `/home/william/Documents/projects/uav/ardupilot/build/sitl'
Build failed
 -> task in 'objs/AP_Soaring' failed (exit status 1): 
        {task 140696087162192: cxx AP_Soaring.cpp -> AP_Soaring.cpp.0.o}
 (run with -v to display more information)
SIM_VEHICLE: Build failed
SIM_VEHICLE: Killing tasks

That’s not the whole output of the command; it’s just where the error happens. I can post the whole output, if needed. A friend of mine who has done the same some days or weeks ago on a similar system running Manjaro has not run into this error.