SITL Setup Problem

After following the instructions for setting up SITL from this page in the documentation:

I have hit a roadblock at:

Whenever I try to run in really any folder, I’ve tried quite a few… I always get some bash error where it doesn’t recognize that command.

This is the error:

I cannot find videos with a real explanation for setting this stuff up or other websites so I am stuck.

Any help you could provide would be awesome. :slight_smile: Thank you.

I’m on Ubuntu and dont know the difference between the Ubuntu and Windows version, but it seems that there is a path missing, maybe the ardupilot_path.

You could try to target this .py directly, try:

../Tools/autotest/ --map --console


hi - I had the same problem last night, this article solved the problem

#Thinking about this, your error is basically “not #found” which may mean that Cygwin #environment doesn’t know where to look for It is possible you missed this #line in the instructions:

#Add the following line to the end of .bashrc

#export PATH=$PATH:$HOME/ardupilot/Tools