SITL & Miniconda (Linux [Ubuntu 16.04] )


I did the miniconda setup for a project . After this installation, I can not run SITL.

I have a few quesiton

1- Does SITL require Python 2.7 only ?

2- Does Miniconda change the path ? Because is into miniconda/bin file


Also the error can be seen from picture above . Some packages and functions are not found


Traceback (most recent call last):
File “/home/mehmet/miniconda3/bin/”, line 12, in
import serial, Queue, select
ModuleNotFoundError: No module named ‘Queue’
SIM_VEHICLE: MAVProxy exited
SIM_VEHICLE: Killing tasks

Thanks for your time and help

Regards Mehmet

SITL uses MAVProxy as the GCS. MAVProxy isn’t yet compatible with Python 3.x, so you’ll need to run under Python 2.7.

Otherwise use --no-mavproxy when runnig and use a different GCS.

Dear @stephendade

I created an environment with Python v2.7 into Condo and try to run SITL in this environment, but I got same error. Also I add Queue file into manually , at this time give other error ( such as: no readm() function ) . I will try with --no mavproxy.

Dear @stephendade

Yes it works--no-mavproxy and I use APMPlanner. Do you know a easy way of takeoff ( like arm throttle / takeoff 40)f in the APMPlanner . There is no takeoff command in quick actions tabs and also I could not be successful with waypoint . I set a takeoff point but I always get cmd 22 error and 400

Queue is part of Python 2.7. Are you able to double-check you’re running 2.7?

Are you able to get the vehicle to arm?

Dear @stephendade

1 - My env_copter environment uses Python 2.7

2- Yes , I can arm , When the copter is stabilized or guided mode



Ok, if it won’t arm in AUTO mode, that could be due to a mission not being loaded

Dear @stephendade

I tried with a mission. I set a point as the take-off point, but the result is same. Thanks for support

I solved the issue , thanks for your support again