SITL map stuck at "Map downloading 2" (Probably doesn't run)


I’m new to APM so sorry if this has been asked a million times. I tried to search for a solution, but didn’t find one.

I’m trying to run ArudCopter under SITL, but I ran into some problems. After trying the instructions in the wiki (which I think are outdated) I tried the installer script from this page:

And that seem to work - The installation seem to work okay, and after running the ArduCopter (pressing 2 on the menu) it looks like it’s running. I’m seeing a map window, and a console window (which says “Ready to FLY ublox”).
BUT the map has a message saying “Map download 35”, which counts down to 2 and stays there (It takes like 20 minutes to get from 35 to 2, and I waited like an hour more, but it didn’t continue its count).

Other than that, I think its working. I’m not sure - ‘arm’ and ‘takeoff’ did stuff. But I can’t really see anything on the unloaded map.

So, where can I get more info on the running simulation? And how can I debug the map thing?


Nice that the script worked for you. :slight_smile:
Regarding you map problem; Have a look at this discussion: ->!topic … dmZl_LZ5B4

Long story short: Maximize your map-window and select another map provider from the “View -> Service” meny.

Ah! That did it. I’m using MicrosoftSat now and it’s working well.

Any tips on how to connect the simulated quad to a mission planner and why doesn’t it take off will be very welcome. I’ll dig in the docs later tonight.

Thanks for you help

Cool. :slight_smile:
You’ll find the answers to your questions in the guides on the RCG-thread.

Basically, you need to specify an IP-adress in your startup command, and connect MP using UDP.
The copter needs to be armed and RC_3 set to >1500 to take off.
Also, don’t forget to check out the MavProxy documentation, to get the most out of it.