SITL Installation Problems; - git submodule --init --recursive;

Hey there guys, This is my first post here and I hope to come to you guys with more interesting stuff in the future besides problems. Also, I hope I read and applied the guidelines well. I’m hoping that this solution will help others in time to come too since I’m not the only one on campus encountering this problem. Also, I’m pretty new to linux.

Some prologue information: I’m using a fresh install of Ubuntu 16.04 lts, everything is up to date.

I was following the instructions here:

however when I attempt the step:

git submodule --init --recursive

It looks like it works, up until it gets to the last submodule. I attempt to enter it a second time to receive this error:

Cloning into 'libraries/AP_HAL_F4Light/hardware/STM32F4xx_DSP_StdPeriph_Lib_V1.1.0/Libraries'...
fatal: unable to connect to[0:]: errno=Connection timed out[1:]: errno=Connection timed out
fatal: clone of 'git://' into submodule path 'libraries/AP_HAL_F4Light/hardware/STM32F4xx_DSP_StdPeriph_Lib_V1.1.0/Libraries' failed 

I tried manually finding the submodule and cloning into the directory myself. This still returns the same error when attempting the git submodule command.

I continued further and followed the subsequent instructions, thinking that maybe my manual placing of the files was correct.

when I enter -w

This is the output I recieve:

SIM_VEHICLE: Killing tasks
SIM_VEHICLE: Starting up at -35.363261,149.165230,584,353 (CMAC)
SIM_VEHICLE: Configure waf
SIM_VEHICLE: "/home/rconw/ardupilot/modules/waf/waf-light" "configure" "--board" "sitl"
Traceback (most recent call last):
  File "/home/rconw/ardupilot/Tools/autotest/", line 995, in <module>
    do_build(vehicle_dir, cmd_opts, frame_infos)
  File "/home/rconw/ardupilot/Tools/autotest/", line 372, in do_build
    return do_build_waf(opts, frame_options)
  File "/home/rconw/ardupilot/Tools/autotest/", line 324, in do_build_waf
    run_cmd_blocking("Configure waf", cmd_configure, check=True)
  File "/home/rconw/ardupilot/Tools/autotest/", line 451, in run_cmd_blocking
    p = subprocess.Popen(cmd, **kw)
  File "/usr/lib/python2.7/", line 711, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/", line 1343, in _execute_child
    raise child_exception
OSError: [Errno 2] No such file or directory
SIM_VEHICLE: Killing tasks

which appears to be a problem with python. Not the directory that I

There is other pertinent information to provide.
I am running the latest python version, I’ve attempted to run the pip commands both in sudo and not. I’ve updated pip and used the “pip” and “pip2” commands. Each attempt was done on a clean system and independently of each other.

I’d really appreciate any help that might get SITL running.

1 Like

Problem has been solved.

The problem was a firewall issue. After connecting to a different access point the original command worked flawlessly.

Hope this helps any other students stuck on campuses that have archaic firewall restrictions!

sorry ! but i dont understand what are you saying