SITL Compile Failed on building AP_Soaring.cpp

Compiling SITL fails, with the below error:

../../libraries/AP_Soaring/AP_Soaring.cpp: In constructor ‘SoaringController::SoaringController(AP_TECS&, const AP_Vehicle::FixedWing&)’:
../../libraries/AP_Soaring/AP_Soaring.cpp:171:17: error: member ‘SoaringController::_polarParams’ is used uninitialized [-Werror=uninitialized]
  171 |     _speedToFly(_polarParams),
      |                 ^~~~~~~~~~~~
compilation terminated due to -Wfatal-errors.
cc1plus: some warnings being treated as errors

Waf: Leaving directory `/home/krishnan/Coding/TJHSST/TJUAV/ardupilot/build/sitl'
Build failed
 -> task in 'objs/AP_Soaring' failed (exit status 1): 
        {task 140141097210976: cxx AP_Soaring.cpp -> AP_Soaring.cpp.0.o}
 (run with -v to display more information)
SIM_VEHICLE: Build failed
SIM_VEHICLE: Killing tasks

Some additional information: I am on Arch, and all packages (including gcc) are completely up-to-date (after a sudo pacman -Syu). I took a look at this, and was wondering if there is another such patch necessary to fix this error.

The exact configuration was working perfectly for the past few months, until SITL decided to re-compile the files again when running ardupilot/Tools/autotest/ --no-mavproxy -L CUSTOM_LOCATION -v ArduPlane --add-param-file ardupilot/Tools/autotest/default_params/custom.parm (the same command I’ve been running for a while now).

I am currently on ArduPilot/ardupilot:Plane-4.2 on commit 44735215e5bf4dc26b55c1c3b0d361188c2927d1 in order to keep firmware consistent. However, I have tried with the latest origin/master and got the same error.

My ./waf has been configured as: ./waf configure --board sitl --debug and ./waf plane.

Any help is appreciated, Thanks in advance!