[SITL Bug]SITL Quadplane can’t be controlled at QLoiter mode or QStabilize mode

Today I tried again and the symptom was same.

Even in QLoiter mode. my version was Arduplane 4.6.0 dev.

Parameter.param (27.4 KB)

and when I disarm in the mid-air(450m), the altitude not decreased well. only 1m decrease at about 0.5secs.

very slow.

I believe I found the reason of problem.

When I change the “SIM_BATT_VOLTAGE” parameter and “SIM_BATT_CAP_AH” parameter, the aircraft roll and pitches very much.

I’m testing plugin that calculate distance remaining as per voltage. so I set “SIM_BATT_VOLTAGE” to 50.

Will this problem solved soon? or Will this problem won’t be fixed for long time?

The problem still persists…

I believe changing “SIM_BATT_VOLTAGE” and “SIM_BATT_CAP_AH” parameter create the problem or make it worse,

and old firmwares also have this problem even though I don’t touch “SIM_BATT_VOLATGE” and “SIM_BATT_CAP_AH” parameters.

I hope future SITL version can support fuction that can change “SIM_BATT_VOLTAGE” parameters.